[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RiscPC Xfree86 keyboard mapping


I've searched the mailing lists and newsgroups for information about this and found problems of this nature but haven't been able to find anything conclusive. If there is a solution somewhere please could you point me at it?

I have an Acorn StrongARM RiscPC running Debian testing (all latest packages). XFree86 is working okay (via fbdev), with the exception of one thing - the keyboard mapping in XFree86. The keyboard is a standard UK PS2 keyboard plugged into the Acorn's PS2 port. The keyboard mapping is fine under the console.

Currently my XF86config-4 says:

Section "InputDevice"
        Identifier      "Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "riscpc"
        Option          "XkbLayout"     "uk"

The space bar doesn't work, and various other keys (notably function keys) don't seem to work either. I know it isn't right but it is the best I have been able to come up with. When I quit X I can see the following error in the startup messages:

The XKEYBOARD keymap compiler (xkbcomp) reports:
Error:            Can't find file "pc/uk" for symbols include
                  Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server

I have also tried:

Section "InputDevice"
        Identifier      "Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
 	Option		"XkbRules"	"xfree86"
 	Option		"XkbModel"	"riscpc"
 	Option		"XkbLayout"	"gb"

but that is far worse - the keys either don't work or produce random output. I get the same error in the X startup messages.

Does anyone have any input on how to get the keyboard to work properly?

Thanks for your help.



Reply to: