[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No network under Netwinder install

Leonard Sitongia wrote:

I'm trying to install stable, and am in a catch-22 of sorts. I net boot tftpboot.img but when I'm in the installation program, there's no network. I have an early DM model. I've never gotten my eth1 working, and I see the tulip_upgd.o but I can use it because I don't have a running system (new 10GB disk I've installed). No eth0 is in the dmesg output.

Is there a fix to this fix I'm in?

Here's roughly how I install Debian on Netwinder - it works nicely if you
have a reasonable (cable) net connection and means you only need to download
the tftpboot.img file locally - the rest is installed "live" :

* You MUST (IME) have NeTTrom 2.3.3 installed in flash.  Do that first!
  (If you've got no running distro, you'll need to do this via serial cable
   and Xmodem from another machine)
* Put tftpboot.img on a suitable tftp server on your network
* Reboot NW to NeTTrom - hit a key so it doesn't boot the kernel
* Put network cable in "10baseT" socket (the Ne2000 card)
* Enter the following commands to NeTTrom:
  setenv netconfig_eth0 flash
  setenv eth0_ip              (change to suit your network)
  setenv kernconfig tftp
  setenv kerntftpserver          (change to be your tftp server)
  setenv kerntftpfile /boot/tftpboot.img     (or wherever you put it)
  setenv kerndev /dev/ram0
  setenv rootdev /dev/ram0
* From here follow the onscreen instructions - you're running the
   debian installer.  *BUT*  it failed to talk to the network, so as soon as
   you can, go to a shell console (alt-f2) then enter "insmod old_tulip"
   (If you just do "insmod tulip" it goes 'nuts' then locks up the machine)
   You'll need to move the ethernet cable to the 10/100 socket now, too.

* I used http://ftp.uk.debian.org/ as the main server for installing from
   as the us.debian.org server seems not to be complete / drops connections.

I've been running Woody on the Netwinder for a while now with no ills.  The
installer for this seemed a bit knackered for Netwinder though, so I install
potato, then fix up the sources.list to point to woody, apt-get update and then
apt-get dist-upgrade.  Works a treat.

After installation, you'll need to go back to NeTTrom and:
  setenv kernconfig fs
  setenv kerndev /dev/hda1                 (change to suit if needed)
  setenv rootdev /dev/hda1                 (change to suit...)
  setenv kernfile /boot/vmlinuz            (you remembered where it was? :)

With Woody, I run a home cooked 2.4.13-ac5-rmk2 kernel on mine.  Seems more
stable than any 2.2 I tried, or indeed more stable than the the 2.4's in the
RedHat distro!

To convince the NW to use the tulip card as preference, I found that:
* Put "alias eth1 tulip"   (old_tulip if you're using potato instead of woody)
  in /etc/modules.conf
* Edit /etc/network/interfaces to say eth1 instead of eth0

It took a while and some sweat to determine that this was a good/simple way of
installing, but may not be optimal if you have local media.

E&OE excepted here.  Follow your nose at prompts incase I typo'd or braino'd.
Maybe I'll put together a more detailed webpage about installing Debian on a
Netwinder - I seem to spend a lot of my time doing this these days!.  :-)


(PS: Thanks to Peter Naulls for prodding and handholding first time around)

Reply to: