[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ICEs, libc6, yp

Jim Pick wrote:

> Adam C Powell IV <hazelsct@mit.edu> writes:
> > The question is, are intermittent non-reproducible ICEs to be expected
> > on this platform?  What might this mean for autobuilding- especially of
> > big packages; or is ARM not yet at the level of maturity where we have
> > an autobuilder?
> >
> > This is all with gcc 2.95.2-0pre1 from the Debian mirrors.
> For the record, I get those on my NetWinder too.  Not too frequent -
> but frequent enough that it interrupts some of the big package builds.
> I'm not sure if this is a software problem or perhaps even a hardware
> problem (I have an early (rev4) NetWinder).  Possibly a different
> kernel version might help.

Okay, I'll just live with it, and rebuild multiple times when there is an ICE.
If it is reproducible, I'll bug report properly.

> > Also, on the assertion problem with GNOME apps ("BUG IN DYNAMIC LINKER
> > ld.so: ... Assertion `! "unexpected dynamic reloc type"' failed!"),
> One of the libraries was built without -fPIC.
> > is there a way I can figure out which library was not built
> > properly?  The gnome-hello test programs all run fine, but
> > e.g. e-conf does not.
> objdump --dynamic-reloc <library>

> Make sure you don't have R_ARM_PC24 records.

Akha!  The last lib I checked, libIIOP.so, has these symbols, but none of the
other six which e-conf links but gnome-hello-... doesn't has them, so that is
the only culprit.  I'll have to check on ssh later.

They look like system calls though- things like strcasecmp and eval_hostname.
I'll look into the Makefiles.  Thanks!

> Rebuilding should be as easy as "debian/rules binary" after you've
> unpacked the source using "dpkg-source -x".  (Actually, for glibc, you
> need to have the kernel headers unpacked and installed into the proper
> place too)

Okay, will do.  The conflict is with a new version of libdb2, which is required
by man-db, so it's somewhat important.

> > Oh, also, out-of-box, gdm just repeatedly starts the X server, changes
> > the background color, and crashes the X server, over and over again.
> > However, if you get rid of :1 in the X server line of /etc/gdm/gdm.conf,
> > it starts very nicely, but the default Xsession bounces me back to the
> > greeter, and the Debian and GNOME sessions just sit there running xrdb
> > forever.
> Um, I don't know.  I've never tried gdm.  I know the X packages
> definitely need some work.  However, I don't even have my NetWinder
> plugged into a monitor.  I got X to build cleanly - but that doesn't
> mean it runs all that cleanly.

That makes sense. :-)  I'll check xrdb and see if I can find a problem there.

Philip Blundell wrote:

> >> Last question: is there some reason NIS doesn't work on ARM?  I have
> >> followed the same instructions for a client as on Intel (where it
> >> worked), but keep getting YPBINDPROC_DOMAIN: Domain not bound.
> >
> >I haven't tried NIS on ARM either.
> NIS is fine on my NetWinder using the Debian binaries.

Hmm.  Okay, that's good to know, I'll try everything again.

Thanks very much!!

-Adam P.

Reply to: