[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#840892: marked as done (apr-util has unsatisfiable cross Build-Depends)



Your message dated Fri, 09 Dec 2016 17:48:39 +0000
with message-id <E1cFPHj-0003ck-OS@fasolo.debian.org>
and subject line Bug#840892: fixed in apr-util 1.5.4-3
has caused the Debian Bug report #840892,
regarding apr-util has unsatisfiable cross Build-Depends
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
840892: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=840892
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Source: apr-util
Version: 1.5.4-2
Severity: minor
Tags: patch
User: helmutg@debian.org
Usertags: rebootstrap
Control: affects 794103 + src:apr-util

apr-util cannot satisfy its cross Build-Depends:
 * The host architecture binutils is requested, but it conflicts with
   the build architecture binutils, which is requested by
   build-essential. Since build-essential already ensures availability
   of binutils for both architectures, we can simply drop it.
 * The host architecture python is requested, but it can neither be
   installed nor executed. As it is really used as a build tool,
   annotate its dependency with :any.

After applying the attached patch, apr-util still fails to cross build
from source, because it is affected by #794103.

Helmut
diff --minimal -Nru apr-util-1.5.4/debian/changelog apr-util-1.5.4/debian/changelog
--- apr-util-1.5.4/debian/changelog	2016-07-14 12:00:56.000000000 +0200
+++ apr-util-1.5.4/debian/changelog	2016-10-15 21:12:10.000000000 +0200
@@ -1,3 +1,12 @@
+apr-util (1.5.4-2.1) UNRELEASED; urgency=medium
+
+  * Non-maintainer upload.
+  * Fix unsatisfiable cross Build-Depends: (Closes: #-1)
+    + Drop binutils from Build-Depends as it is build-essential.
+    + Annotate Build-Depends: python with :any.
+
+ -- Helmut Grohne <helmut@subdivi.de>  Sat, 15 Oct 2016 21:11:45 +0200
+
 apr-util (1.5.4-2) unstable; urgency=medium
 
   [ Jean-Michel Vourgère ]
diff --minimal -Nru apr-util-1.5.4/debian/control apr-util-1.5.4/debian/control
--- apr-util-1.5.4/debian/control	2016-07-14 11:58:27.000000000 +0200
+++ apr-util-1.5.4/debian/control	2016-10-15 21:12:25.000000000 +0200
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian Apache Maintainers <debian-apache@lists.debian.org>
 Uploaders: Stefan Fritsch <sf@debian.org>, Peter Samuelson <peter@p12n.org>
-Build-Depends: debhelper (>> 9~), autoconf, autotools-dev, mawk, libldap2-dev, libexpat1-dev, libdb-dev, libpcre3-dev, binutils, libapr1-dev (>> 1.4.8-2~), libsqlite3-dev, libpq-dev, python, libmysqlclient-dev, unixodbc-dev, doxygen, libssl-dev
+Build-Depends: debhelper (>> 9~), autoconf, autotools-dev, mawk, libldap2-dev, libexpat1-dev, libdb-dev, libpcre3-dev, libapr1-dev (>> 1.4.8-2~), libsqlite3-dev, libpq-dev, python:any, libmysqlclient-dev, unixodbc-dev, doxygen, libssl-dev
 Standards-Version: 3.9.8
 Vcs-Browser: https://anonscm.debian.org/cgit/pkg-apache/apr-util.git
 Vcs-Git: git://anonscm.debian.org/pkg-apache/apr-util.git

--- End Message ---
--- Begin Message ---
Source: apr-util
Source-Version: 1.5.4-3

We believe that the bug you reported is fixed in the latest version of
apr-util, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 840892@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Stefan Fritsch <sf@debian.org> (supplier of updated apr-util package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Fri, 09 Dec 2016 18:19:55 +0100
Source: apr-util
Binary: libaprutil1 libaprutil1-ldap libaprutil1-dbd-mysql libaprutil1-dbd-sqlite3 libaprutil1-dbd-odbc libaprutil1-dbd-pgsql libaprutil1-dev libaprutil1-dbg
Architecture: source amd64
Version: 1.5.4-3
Distribution: unstable
Urgency: medium
Maintainer: Debian Apache Maintainers <debian-apache@lists.debian.org>
Changed-By: Stefan Fritsch <sf@debian.org>
Description:
 libaprutil1 - Apache Portable Runtime Utility Library
 libaprutil1-dbd-mysql - Apache Portable Runtime Utility Library - MySQL Driver
 libaprutil1-dbd-odbc - Apache Portable Runtime Utility Library - ODBC Driver
 libaprutil1-dbd-pgsql - Apache Portable Runtime Utility Library - PostgreSQL Driver
 libaprutil1-dbd-sqlite3 - Apache Portable Runtime Utility Library - SQLite3 Driver
 libaprutil1-dbg - Apache Portable Runtime Utility Library - Debugging Symbols
 libaprutil1-dev - Apache Portable Runtime Utility Library - Development Headers
 libaprutil1-ldap - Apache Portable Runtime Utility Library - LDAP Driver
Closes: 840892 843206 845823
Changes:
 apr-util (1.5.4-3) unstable; urgency=medium
 .
   [ Helmut Grohne ]
   * Fix unsatisfiable cross Build-Depends: (Closes: #840892)
     + Drop binutils from Build-Depends as it is build-essential.
     + Annotate Build-Depends: python with :any.
 .
   [ Stefan Fritsch ]
   * Enable support for gdbm. Closes: #843206
   * Switch build-depends to default-libmysqlclient-dev. Closes: #845823
Checksums-Sha1:
 4d61187d0c1904b731f652c60d5fa56e77f93bb2 2646 apr-util_1.5.4-3.dsc
 7aa825f806e8a17fbe28db1531f88b443f59a66e 212220 apr-util_1.5.4-3.debian.tar.xz
 1dc6695b8a5bc42eb67f31fc45cf928ffa7b6ff3 8537 apr-util_1.5.4-3_amd64.buildinfo
 f458a5ed0fc8d229fa4ea7d8ad12efae9802ff68 21148 libaprutil1-dbd-mysql_1.5.4-3_amd64.deb
 978eaf73571930b030435d47ad2a8ced02027320 24978 libaprutil1-dbd-odbc_1.5.4-3_amd64.deb
 d25d3e912517a28858c2d219b4d590a7bd5704a5 21174 libaprutil1-dbd-pgsql_1.5.4-3_amd64.deb
 d88775e22ea9116b31d336475217fa414f8e0345 19260 libaprutil1-dbd-sqlite3_1.5.4-3_amd64.deb
 6d7301cbb384d72f38651cdf5d939b7cb1236c93 316804 libaprutil1-dbg_1.5.4-3_amd64.deb
 0813c11c6a804912ff2ab99b0fad11230108927b 380876 libaprutil1-dev_1.5.4-3_amd64.deb
 127687b436666db11ae52bd5e6bbd3e83fe8b030 17376 libaprutil1-ldap_1.5.4-3_amd64.deb
 83b62eb92f1a9995d248723e89c336d6d633c846 85794 libaprutil1_1.5.4-3_amd64.deb
Checksums-Sha256:
 352bbbdf8d4e18014614d5a92da11b599cd04bb30ee03d9f04f26a75626371c7 2646 apr-util_1.5.4-3.dsc
 c5e7bfcdafb16104e324ddb6825b94577a57a5b77b809dc0330e38ecab030efa 212220 apr-util_1.5.4-3.debian.tar.xz
 a5ec43cf7f15c8d1dc7eef2e408de0a4ffd4d8aa0cdb384b558eca98789165d2 8537 apr-util_1.5.4-3_amd64.buildinfo
 2d6f37f290b1dee24924712cd8190d787def4bce8f64494597920828473b733c 21148 libaprutil1-dbd-mysql_1.5.4-3_amd64.deb
 b1c8fc3566729d73c8e3c0951fe3a474f0dc4050020e83ae99f4373596324677 24978 libaprutil1-dbd-odbc_1.5.4-3_amd64.deb
 862d2c139d9b9da3b07c757c4d7f4c07b14e7fdd2afe5ac6489cc96efc118be6 21174 libaprutil1-dbd-pgsql_1.5.4-3_amd64.deb
 96412ecccd381b0aef46aaa87ce02f93da084d7293927c911e09a16d2ba26ed6 19260 libaprutil1-dbd-sqlite3_1.5.4-3_amd64.deb
 7fe0481c901ec4cf7e8e72a81d5fb4b7a17e344a0db0980d1ba99cf7c68d2258 316804 libaprutil1-dbg_1.5.4-3_amd64.deb
 80f9a294ec67c5aeeef45cf8e073a67743718ecbd8bcf5f3587ea7c2e392de0f 380876 libaprutil1-dev_1.5.4-3_amd64.deb
 5a27a33ceb9f5f7754a3ab69b509260d1d5ea0760d5125bbebc5b7ed26cc1a8e 17376 libaprutil1-ldap_1.5.4-3_amd64.deb
 798428a9a84382eabb8a131dc6cb1fb4ea206e23bafca4dba1d562ffc2cce95e 85794 libaprutil1_1.5.4-3_amd64.deb
Files:
 e1f119d9c0daed8bf2e31da7bb72f957 2646 libs optional apr-util_1.5.4-3.dsc
 62d33d204eed12a4d147133aab90531f 212220 libs optional apr-util_1.5.4-3.debian.tar.xz
 f232c01813db4012fda58a214ae60c0d 8537 libs optional apr-util_1.5.4-3_amd64.buildinfo
 fe04b05488410a39e6f9b11972cdac1b 21148 libs optional libaprutil1-dbd-mysql_1.5.4-3_amd64.deb
 8c9614fb42e040bc8e8c13b5639967b8 24978 libs optional libaprutil1-dbd-odbc_1.5.4-3_amd64.deb
 083490b30367d50c1edf3cb18cf843a2 21174 libs optional libaprutil1-dbd-pgsql_1.5.4-3_amd64.deb
 63fb0c56f6e3bdfcef7ce9fb4a127054 19260 libs optional libaprutil1-dbd-sqlite3_1.5.4-3_amd64.deb
 e6a659441113c0e3624824065d8901b1 316804 debug extra libaprutil1-dbg_1.5.4-3_amd64.deb
 8efa8dada5859d4abbf7b552fdaa0e75 380876 libdevel optional libaprutil1-dev_1.5.4-3_amd64.deb
 ae3fdca9c32d5403def3182baac680bf 17376 libs optional libaprutil1-ldap_1.5.4-3_amd64.deb
 4db3bfc35ee48b221a8b1c762612adb0 85794 libs optional libaprutil1_1.5.4-3_amd64.deb

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEOpiNza8JqByyYYsxxodfNUHO/eAFAlhK6VAACgkQxodfNUHO
/eAptg//cwAon7rAZrJCNLBVWJHoIzHZD/c4IMWgvZ3nlb8UMYV+Q45zpVDtEp5C
rAeUcmMoBuuN3L9RamMzjLcsc3HVh9qRT9j7PlGWoCLRgxiUHb95AWL2g6esEEUb
deUKFLIaCCGJOtvUSVD5lEePWfNVTQdvDQnMhFVY25tSEqXNb4EIEn4Jp7QgNKnG
kRYOcYMXl8RfSqayAWl1fAMb+e7BvzrKsBc1krPcWT43wrTqhDOE+KJTb5HlQD2h
2vc+Rtao/d4tIlHPTvmoibkOT6GtrxSsbr78qgGW+Lkbw+SE3FV0vUhgTsfgyCwo
NaaxO4jcdhrGBPt9e8AhtK9IZ2o5Ethb1xm8/cG6Z3SfgZTg7hlgPc6gJ/8BKKPb
OWbWqzVRiyYiQ10h8qdt4T68spUKLVpiQVM0sPrlte0kf/7CR8KJomxKUjKZXvDr
KTkyEkwAev9JZwRT/yXrz3S0nuE5/Jk+FppgeJVrf/uUyj/PnLP2XyOBxJXV6irl
oMc32uIEm5mgOx/5kGYOhQ6RgVH0T8fdL401XVofTxzwq4ZV4F3mGmYHeqWLpzNU
FRfJFyKwX0LcAytU4ztohWacnIxO4uCoIWsj51cDyhem40HKFM3DIPM+tUlnoAO/
s0vzy3DzeR6vCiHOA91A62BowBv8+7vsDJ3qo2HQnNMA/y3xBWE=
=gU/5
-----END PGP SIGNATURE-----

--- End Message ---

Reply to: