[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Wrong Character Encoding in Content-Type that can't be turned off

Our apache server always transmits "charset=ISO-8859-1" in the Content-Type header, even though we set the default charset to "Off". This isn't a problem most of the time, but some of our pages are UTF-8 and since the Content-Type header overrides the charset given in the document these pages show up in the browser using the wrong encoding. We suspect that this might be related to the upgrade to 2.2.22-13 (since it worked before), but before I'm posting a bug report I wanted to make sure it isn't a configuration issue after all.

I already tried (for test reasons) to set the default charset in /etc/apache2/conf.d/charset as well as in the .htaccess file in the directory of the web page, with no effect. I also checked that the whole apache configuration doesn't assign ISO-8859-1 to the file extension of the file (standard .html extension).

Do you have any idea what else might influence the charset decision of apache?

Our /etc/apache2/conf.d/charset just contains AddDefaultCharset Off

Debian version: 7.2
Apache version: 2.2.22-13

Tobias Blass

Reply to: