[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#392349: marked as done (apache 2.2 upgrade breaks, missing Order (authz_host module))



Your message dated Fri, 10 Nov 2006 18:03:06 -0800
with message-id <E1GiiD4-00067S-9J@spohr.debian.org>
and subject line Bug#392349: fixed in apache2 2.2.3-3.1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: apache2
Version: 2.2.3-2
Severity: grave
Justification: renders package unusable

On attempting to start Apache I get this:

root@zev:/usr# /etc/init.d/apache2 start
Starting web server (apache2)...Syntax error on line 141 of
/etc/apache2/apache2.conf:
Invalid command 'Order', perhaps misspelled or defined by a module not
included in the server configuration
 failed!

I found the 'Order' directive belongs to mod_access which is normally
statically linked, but this no longer seems to be the case:

t@zev:/usr# apache2 -l
Compiled in modules:
core.c
mod_log_config.c
mod_logio.c
prefork.c
http_core.c
mod_so.c

So where has mod_access.c and friends gone?

I looked in /etc/apache2/mods-available but doesn't appear to be there.

My Apache versions look like this:

Desired=Unknown/Install/Remove/Purge/Hold
|
Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
||/ Name                         Version        Description
+++-============================-==============-============================================
ii  apache2                      2.2.3-2        Next generation,
scalable, extendable web se
ii  apache2-mpm-prefork          2.2.3-2        Traditional model for
Apache HTTPD 2.1
ii  apache2-utils                2.2.3-2        utility programs for
webservers
ii  apache2.2-common             2.2.3-2        Next generation,
scalable, extendable web se
ii  libapache2-mod-php5          5.1.6-4        server-side,
HTML-embedded scripting languag

Please advise.

Thanks,
Mark


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (200, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-kanotix-1
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages apache2 depends on:
ii  apache2-mpm-prefork           2.2.3-2    Traditional model for Apache HTTPD

apache2 recommends no packages.

-- no debconf information



--- End Message ---
--- Begin Message ---
Source: apache2
Source-Version: 2.2.3-3.1

We believe that the bug you reported is fixed in the latest version of
apache2, which is due to be installed in the Debian FTP archive:

apache2-doc_2.2.3-3.1_all.deb
  to pool/main/a/apache2/apache2-doc_2.2.3-3.1_all.deb
apache2-mpm-event_2.2.3-3.1_i386.deb
  to pool/main/a/apache2/apache2-mpm-event_2.2.3-3.1_i386.deb
apache2-mpm-perchild_2.2.3-3.1_all.deb
  to pool/main/a/apache2/apache2-mpm-perchild_2.2.3-3.1_all.deb
apache2-mpm-prefork_2.2.3-3.1_i386.deb
  to pool/main/a/apache2/apache2-mpm-prefork_2.2.3-3.1_i386.deb
apache2-mpm-worker_2.2.3-3.1_i386.deb
  to pool/main/a/apache2/apache2-mpm-worker_2.2.3-3.1_i386.deb
apache2-prefork-dev_2.2.3-3.1_i386.deb
  to pool/main/a/apache2/apache2-prefork-dev_2.2.3-3.1_i386.deb
apache2-src_2.2.3-3.1_all.deb
  to pool/main/a/apache2/apache2-src_2.2.3-3.1_all.deb
apache2-threaded-dev_2.2.3-3.1_i386.deb
  to pool/main/a/apache2/apache2-threaded-dev_2.2.3-3.1_i386.deb
apache2-utils_2.2.3-3.1_i386.deb
  to pool/main/a/apache2/apache2-utils_2.2.3-3.1_i386.deb
apache2.2-common_2.2.3-3.1_i386.deb
  to pool/main/a/apache2/apache2.2-common_2.2.3-3.1_i386.deb
apache2_2.2.3-3.1.diff.gz
  to pool/main/a/apache2/apache2_2.2.3-3.1.diff.gz
apache2_2.2.3-3.1.dsc
  to pool/main/a/apache2/apache2_2.2.3-3.1.dsc
apache2_2.2.3-3.1_all.deb
  to pool/main/a/apache2/apache2_2.2.3-3.1_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 392349@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Andreas Barth <aba@not.so.argh.org> (supplier of updated apache2 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 10 Nov 2006 15:44:33 +0100
Source: apache2
Binary: apache2-utils apache2-prefork-dev apache2 apache2-mpm-prefork apache2-doc apache2-mpm-event apache2.2-common apache2-mpm-worker apache2-src apache2-threaded-dev apache2-mpm-perchild
Architecture: source all i386
Version: 2.2.3-3.1
Distribution: unstable
Urgency: high
Maintainer: Debian Apache Maintainers <debian-apache@lists.debian.org>
Changed-By: Andreas Barth <aba@not.so.argh.org>
Description: 
 apache2    - Next generation, scalable, extendable web server
 apache2-doc - documentation for apache2
 apache2-mpm-event - Event driven model for Apache HTTPD 2.1
 apache2-mpm-perchild - Transitional package - please remove
 apache2-mpm-prefork - Traditional model for Apache HTTPD 2.1
 apache2-mpm-worker - High speed threaded model for Apache HTTPD 2.1
 apache2-prefork-dev - development headers for apache2
 apache2-src - Apache source code
 apache2-threaded-dev - development headers for apache2
 apache2-utils - utility programs for webservers
 apache2.2-common - Next generation, scalable, extendable web server
Closes: 391393 392349 392352 392701 393913 395976 396678 397310
Changes: 
 apache2 (2.2.3-3.1) unstable; urgency=high
 .
   * Non-maintainer upload.
   * Enable authz_user by default, fix silent authentication breakage.
     Closes: #397310
   * Add default modules if coming from earlier than this version.
     Closes: #392349, #392352, #392701, #393913, #396678, #395976
   * Re-Enable modules cern_meta, dumpio and ext_filter. Closes: #391393
Files: 
 c209a8b2e67d980e11420056ca1726d4 1026 web optional apache2_2.2.3-3.1.dsc
 269b272e144fa0d533d8b8ca44577b31 107694 web optional apache2_2.2.3-3.1.diff.gz
 b3e24c3972f2487a7e0cf2d682d082ea 930160 web optional apache2.2-common_2.2.3-3.1_i386.deb
 466e93ace9f8776e3fa7ad77dd6b2e89 420406 web optional apache2-mpm-worker_2.2.3-3.1_i386.deb
 b8eb3419aa91a192d6cb2865afe9416a 416336 web optional apache2-mpm-prefork_2.2.3-3.1_i386.deb
 b2579c13c81314869d9985b50b0cf1e0 420802 web optional apache2-mpm-event_2.2.3-3.1_i386.deb
 8a28b057ea30892249ca867c901d09dc 340364 web optional apache2-utils_2.2.3-3.1_i386.deb
 7b284b4e263698e12b001187e91cecb7 403018 devel optional apache2-prefork-dev_2.2.3-3.1_i386.deb
 6cf015bbc09741692872a200f211a840 403590 devel optional apache2-threaded-dev_2.2.3-3.1_i386.deb
 45d5790d81de61d92f41a21101372142 271648 web optional apache2-mpm-perchild_2.2.3-3.1_all.deb
 026fdf5dcbf992d69045ed37c8fb6bbc 38276 web optional apache2_2.2.3-3.1_all.deb
 f0b3552b1f424937b6ccca82faf8941f 2198756 doc optional apache2-doc_2.2.3-3.1_all.deb
 fbb39c0b9287cceffc986839026dc8be 6670986 devel extra apache2-src_2.2.3-3.1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFFVQtXmdOZoew2oYURAiiFAJ0fd9r44leu/xEYh8dwFIA8vFl+vQCfSCeq
yGPHkGxJVlaUI/aoB87lU8Q=
=CBBM
-----END PGP SIGNATURE-----


--- End Message ---

Reply to: