[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apache2 not processing php

Hi folks,

I am sure this is a really simple to fix problem but I have struggled for hours without success. For some reason apache2 doesn't seem to want to process php. Well that's not 100% correct. When I request the default page http://www.crazysquirrel.com/ it seems to have a stab at processing but fails all over the place. When I request a particular page, such as http://www.crazysquirrel.com/index.php, I just get the file back unprocessed. The two links should show the behaviour unless I have managed to fix it.

I have apache1.3 installed but it is stopped - php was working fine with it. I have installed libapache2-mod-php4 and all went well (I have tried reinstalling it as well and that didn't fix the problem). I have checked that php4.conf and php4.load are symlinked into /etc/apache2/mods-enabled and the contents of the files look correct. I have tried including the line

PHPINIDir /etc/php4/apache2/

at the top of php4.conf but that didn't fix the problem either.

Any ideas? I'm totally stuck.

Many thanks.

Reply to: