[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#253306: apache-dev apt-get dependency problem



Package: apache-dev
Version: 1.3.26-0wo

Dependencies cannot be satisfied when installing apache-dev, see below...


Output from aptitude for apache-dev
  Source Package: apache
  --\ Depends
    --- libc6 (>= 2.2.4-4)
    --- libdb2 (>= 2:2.7.7.0-7)                 
    --- libexpat1 (>= 1.95.2-6)       
    --- apache-common (>= 1.3.26-0)   
    --- apache-common (< 1.3.27-0) (UNSATISFIED)
    --- libdb2-dev (>= 2.7.7-2.1) (UNAVAILABLE)
    --- libexpat1-dev (UNAVAILABLE)


www:~/mod_throttle-3.1.2# apt-get update
Hit http://security.debian.org stable/updates/main Packages
Hit http://security.debian.org stable/updates/main Release
Hit http://security.debian.org stable/updates/contrib Packages
Hit http://security.debian.org stable/updates/contrib Release
Hit http://security.debian.org stable/updates/non-free Packages
Hit http://security.debian.org stable/updates/non-free Release
Reading Package Lists... Done

www:~/mod_throttle-3.1.2# dpkg -l apache
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err:
uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-==========================================
==
ii  apache         1.3.29.0.2-4   Versatile, high-performance HTTP server

www:~/mod_throttle-3.1.2# apt-get install apache-dev
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  apache-dev: Depends: apache-common (< 1.3.27-0) but 1.3.29.0.2-4 is to be
installed
              Depends: libdb2-dev (>= 2.7.7-2.1) but it is not installable
              Depends: libexpat1-dev but it is not installable
E: Broken packages



System info...
Linux www 2.4.22 #1 Tue Aug 26 20:36:53 BST 2003 ppc GNU/Linux
PPC on IBM RS6000 running Debian 3.0rev2

www:~/mod_throttle-3.1.2# ls -l /lib/libc.so.6
lrwxrwxrwx    1 root     root           13 Apr 11 00:06 /lib/libc.so.6 ->
libc-2.3.2.so






Reply to: