[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#239416: apache: Problem with suexec upgrading woody -> sarge

Hi Florian,

> Hi!
> I upgraded from woody to sarge and dpkg exited while configuration:
> ---
> Setting up apache ( ...
> Starting web server: apache failed
> invoke-rc.d: initscript apache, action "start" failed.
> dpkg: error processing apache (--configure):
>  subprocess post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of libapache-mod-ssl:
>  libapache-mod-ssl depends on apache (>= | apache-perl (>=
>; however:
>   Package apache is not configured yet.
>   Package apache-perl is not installed.
> dpkg: error processing libapache-mod-ssl (--configure):
>  dependency problems - leaving unconfigured
> Errors were encountered while processing:
>  apache
>  libapache-mod-ssl
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> --
> Then I tried to start apache (using apachectl start) and got an error,
> that suexec isn't configured right. After
> dpkg-divert --local --divert /usr/lib/apache/suexec --rename
> /usr/lib/apache/suexec.disabled
> this problem was solved and the apache starts.


> Now there's no suexec or suexec.disabled file inside /usr/lib/apache and
> I had to disable every suexec (user/group) directive in my virtual
> hosts.
> Perhaps this helps?

It can be the reason.. yes..

I will try to look at it as soon as i can put my hands on a woody box.


<user> fajita: step one
<fajita> Whatever the problem, step one is always to look in the error log.
<user> fajita: step two
<fajita> When in danger or in doubt, step two is to scream and shout.

Reply to: