[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#237782: apache: VirtualHost Configuration problems in newer versions?

Thom May wrote:
* Stefan Andersson (stefan@ryo-ohkI.mine.nu) wrote :
Package: apache
Severity: normal

Hi. I have a really strange problem.
Since i upgraded to the latest version of apache (sid) my vhost
configuration just stopped working. and it has worked for the last 2-3
years atleast .. really strange. and i've even tried apache2 and the old
vhost config works there too .. but not in the latest version released
in debian. here follows the errors i get when trying to start apache.
Did you try reading the error message?
VirtualHost overlaps with VirtualHost, the first has precedence, perhaps you need a NameVirtualHost directive

You've got a bunch of duplicate VirtualHost entries, but no NameVirtualHost
line for the IP. Add one. You'll be much happier.
Not a bug.

Well. I'm not that much of a newbie ;)
I _have_ a NameVirtualHost directive for each ip:port that i use.
The strange thing is that it just stopped working. Dunno if apache ignores my NVH lines then ..

Reply to: