[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apache2, tomcat4 and mod_jk/mod_jk2

I've originally posted this message to debian-java but I got no answers, I cross post here since I think it's relevant anyway.

I was unable to find mod_jk2 in Debian, so I tried to compile it myself
from sources got from apache site, but I went in trouble :(

Packages installed includes:
apache2-common 2.0.47-1
apache2-dev    2.0.47-1
apache2-mpm-wo 2.0.47-1
libapr0        2.0.47-1
libtomcat4-jav 4.1.28-1
tomcat4        4.1.28-1
tomcat4-admin  4.1.28-1

I then got jakarta-tomcat-connectors-jk-1.2-src-current.tar.gz from
jakarta site, untarred it, and following build instructions:

./configure -with-apxs=/usr/bin/apxs2

After that I do a "make", and after a couple file compiled fine it stops
telling me it does not find apr header files like apr_network_io.h and

After researching a bit, I find these files in the dir
/usr/include/apr-0, so  I modify "by hand" a couple makefiles including
this dir in the include sources and I try to recompile.
This time some more files are compiled but the process fails with this

make[1]: Leaving directory
Making all in apache-2.0
make[1]: Entering directory
Makefile:21: /build/config_vars.mk: No such file or directory
make[1]: *** No rule to make target `/build/config_vars.mk'.  Stop.
make[1]: Leaving directory
make: *** [all-recursive] Error 1

I also tried to compile the newest version of the connector (jk2) from
the following sources:

but this time the process does not even starts, here is the output of
make after having ./configure-d it:
list=' server/apache2'; \
for i in $list; do \
        echo "Making $target in $i"; \
        if test "$i" != "."; then \
        (cd $i && make) || exit 1; \
fi; \
Making  in server/apache2
make[1]: Entering directory
mkdir -p ../../../build/jk2/apache2
/build/libtool  --mode=compile gcc  -pipe -I/usr/include/xmltok
-I/usr/include/openssl -O2 -pipe -I/usr/include/xmltok
-I/usr/include/openssl -O2 -pthread    -DLINUX=2 -D_REENTRANT
-I../../include -I/usr/include/apache2  -I /usr/lib/j2sdk1.4.2/include
-I /usr/lib/j2sdk1.4.2/include/linux  -DCHUNK_SIZE=4096 -DUSE_APACHE_MD5
-DHAS_APR   -c ../../common/jk_channel.c -o
make[1]: /build/libtool: Command not found
make[1]: *** [../../../build/jk2/apache2/jk_channel.lo] Error 127
make[1]: Leaving directory
make: *** [jk2-build] Error 1

I'm really stuck.

Con anyone help me having mod_jk or mod_jk2 (preferred) for apache2?

Thanks very much for any help,

P.S.: Please be kind with me, I'm relatively new to Debian with source

Reply to: