[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#207498: marked as done (apache_1.3.27.0-2 cannot authenticate through PAM)

Your message dated Tue, 16 Dec 2003 15:15:51 +0100 (CET)
with message-id <Pine.LNX.4.58.0312161515300.28918@trider-g7.ext.fabbione.net>
and subject line Bug#207498: can't reproduce
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 27 Aug 2003 13:55:30 +0000
>From marga@maxy.com.ar Wed Aug 27 08:55:28 2003
Return-path: <marga@maxy.com.ar>
Received: from mta5.fibertel.com.ar (mail.fibertel.com.ar) [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 19s0lk-0005ij-00; Wed, 27 Aug 2003 08:55:28 -0500
Received: from rivero ( by mail.fibertel.com.ar (7.0.019) (authenticated as luisman)
        id 3F4CB7C8000007BE; Wed, 27 Aug 2003 10:54:55 -0300
Received: from Spooler by rivero (Mercury/32 v3.32) ID MO003A1A;
  27 Aug 03 10:56:31 -0300
Received: from spooler by rivero.com.ar (Mercury/32 v3.32); 27 Aug 03 10:55:47 -0300
Received: from peperina.rivero ( by mail2.rivero.com.ar (Mercury/32 v3.32) with ESMTP ID MG003A19;
   27 Aug 03 10:55:26 -0300
Received: from marga by peperina.rivero with local (Exim 3.36 #1 (Debian))
	id 19s0ke-0006tH-00; Wed, 27 Aug 2003 10:54:20 -0300
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Type: text/plain; charset="ISO-8859-1"
From: Margarita Manterola <debian@marga.com.ar>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: apache_1.3.27.0-2 cannot authenticate through PAM
X-Mailer: reportbug 2.20
Date: Wed, 27 Aug 2003 10:54:20 -0300
Message-Id: <E19s0ke-0006tH-00@peperina.rivero>
Sender: Margarita Manterola <marga@maxy.com.ar>
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-4.8 required=4.0
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_8_27 (

Package: apache
Version: 1.3.26-0woody3
Severity: normal

I had a site that used PAM Basic authentication through the
libapache-mod-auth-pam packages. It worked alright until I upgraded to
the new apache version apache_1.3.27.0-2.  After that, trying to
authenticate even to basic PAM configurations was impossible.

To test it, we used:

------ /etc/pam.d/httpd ------

auth     required       pam_permit.so
auth     required       pam_warn.so
account  required       pam_unix.so


This should always work, but it didn't.  While using only the pam_permit
module works fine.  We also tried a php_pam authentication module, to
authenticate through PHP instead of Basic Authentication, with the same

After tearing our hairs out, we downgraded the Apache version to the one 
in woody, and everything started working again.  Therefore this does not
seem to be a PAM problem, or a libapache-mod-auth-pam problem, since we
only had to downgrade "apache" and "apache-common" packages, AND the php
module does not use libapache-mod-auth-pam.

I hope you can fix this!
Margarita Manterola.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux peperina 2.4.20-1-686 #1 Sat Mar 22 13:16:21 EST 2003 i686
Locale: LANG=en_US, LC_CTYPE=en_US

Versions of packages apache depends on:
ii  apache-common             1.3.26-0woody3 Support files for all Apache webse
ii  dpkg                      1.10.10        Package maintenance system for Deb
ii  libc6                     2.3.2-3        GNU C Library: Shared libraries an
ii  libdb2                    2:    The Berkeley database routines (ru
ii  libexpat1                 1.95.6-4       XML parsing C library - runtime li
ii  logrotate                 3.6.5-2        Log rotation utility
ii  mime-support              3.23-1         MIME files 'mime.types' & 'mailcap
ii  perl [perl5]              5.8.0-19       Larry Wall's Practical Extraction 

-- debconf information excluded

Received: (at 207498-done) by bugs.debian.org; 16 Dec 2003 14:35:15 +0000
>From fabbione@fabbione.net Tue Dec 16 08:35:06 2003
Return-path: <fabbione@fabbione.net>
Received: from port5.ds1-sby.adsl.cybercity.dk (trider-g7.fabbione.net) [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AWFzZ-0003Kx-00; Tue, 16 Dec 2003 08:16:05 -0600
Received: from trider-g7.ext.fabbione.net (port5.ds1-sby.adsl.cybercity.dk [])
	by trider-g7.fabbione.net (Postfix) with ESMTP id 017B317;
	Tue, 16 Dec 2003 15:16:00 +0100 (CET)
Date: Tue, 16 Dec 2003 15:15:51 +0100 (CET)
From: Fabio Massimo Di Nitto <fabbione@fabbione.net>
Sender: fabbione@trider-g7.ext.fabbione.net
To: Margarita Manterola <debian@marga.com.ar>
Cc: 207498-done@bugs.debian.org
Subject: Re: Bug#207498: can't reproduce
In-Reply-To: <20031216140152.GA7687@localhost>
Message-ID: <Pine.LNX.4.58.0312161515300.28918@trider-g7.ext.fabbione.net>
References: <Pine.LNX.4.58.0312081512250.13978@trider-g7.ext.fabbione.net>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
Delivered-To: 207498-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 
	(1.212-2003-09-23-exp) on master.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=FOOASDF,HAS_BUG_NUMBER 

Hi Margarita,
	thanks for the information. I am closing the bug.


On Tue, 16 Dec 2003, Margarita Manterola wrote:

> Hola Fabio Massimo Di Nitto!
> > 	I made a simple test to verify this problem and I cannot reproduce
> > it. PAM authentication is working fine with the latest packages so there
> > is really nothing to fix. If noone is experiencing this problem i will
> > close this bug in 2 weeks from now.
> Ok.  I tested it on two different machines (the one that had been bugged
> and a new one) and the bug wasn't there.  Evidently this bug was related
> to some other package, and upgrading that package has resulted in the
> disappearance of the bug...
> It's really weird, but I guess it's ok to close it, since I cannot
> reproduce in the machine where it used to happen, with the same
> configuration as before.

Our mission: make IPv6 the default IP protocol
"We are on a mission from God" - Elwood Blues


Reply to: