[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apache 2.0.39: missing suexec.log file & then it still doesn't work

Package: apache2-common
Version: 2.0.39-2

Note: this has not been sent to the bug database because this package is
not available in unstable (apache2-common_2.0.39-2_i386.deb).

suexec.load in /etc/apache2/mods-enabled:
LoadModule suexec_module /usr/lib/apache2/modules/mod_suexec.so

suexec.conf in /etc/apache2/mods-enabled:
SuexecUserGroup adam adam

1. The error.log does not say what log file is missing:

... failed to open log file, referer: http://...
... fopen: Permission denied, referer: http://...

2. /usr/lib/apache2/suexec2 -V tells me that the log path is

3. I touch /var/log/apache2/suexec.log (644)

4. Log file can still not be written to.

5. chmod 666 suexec.log.

6. Log file can finally be written to. NB: this is not secure as anyone
can modify the log file.

And the CGI script still does not work. I'm stumped:

>From suexec.log:
[2002-07-18 23:45:29]: uid: (1000/adam) gid: (1000/1000) cmd: image.lisp
[2002-07-18 23:45:29]: failed to setgid (1000: image.lisp)

-rwx------    1 adam     adam          737 Jul 18 22:36 image.lisp

It is clear that the script already has the correct permissions and
ownership. From /etc/group adam has a GID of 1000.


PS: I am not subscribed to debian-apache. I'll monitor the archives.

To UNSUBSCRIBE, email to debian-apache-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: