[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian9 amd64 failure to connect to lvmetad, falling back to device scanning

On Fri, May 19, 2017 at 11:12:25AM +0200, Francesco Pietra wrote:
    "It is not required for normal usage"

  The fact is that the X79-based computer does not offer a login
  possibility, it goes to disk scanning (kernel et al) for hours (at
  least 4hr).

  Access to file was only possible from a LAN-connected other computer
  (laptop VAIO) or booting from Super Grub2 disk.

  Whether all issues arise from inability to connect to lvmetad, I
  cannot say. I am no system analyzer. I merely need the X79-GPU-based
  machine for applications (molecular dynamics with recent CUDA).

Personally, I doubt that your GPU (Graphics Processing Unit) is related
to how the disks are access, but perhaps you've got a very special

Also, I'm not sure what issue you're... Oh, I see what's happening!

Your server is booting, but not providing a login. You ARE able to log
into the server using another computer on the network. This means that
the server HAS booted from the disk(s). LVM is *not* your problem (if it
was, the system would probably not be able to load
/etc/network/interfaces in order to bring up the network, nor the SSH
daemon, nor the user's home directory ...)

The issue you're having is more likely with that GPU. Can you log in on
a VT console (press Ctrl+Alt+F2 to see if you get a login prompt)? When
you log in from the VAIO, what does "grep -E 'WW|EE'
/var/log/Xorg.0.log" show (on the server, perhaps as root)?

  On Fri, May 19, 2017 at 10:24 AM, Darac Marjal
  <[1]mailinglist@darac.org.uk> wrote:

    On Fri, May 19, 2017 at 10:17:44AM +0200, Francesco Pietra wrote:

        On a vintage VAIO I have no problems with amd64 stretch. With a
        raid1-based on the X79 chip, upgrading from jessie to stretch
      (I need
        a higher CUDA version than available on jessie for latest
        experimental NAMD molecular dynamics) went on regularly.
      However, the

        # systemctl set-default multi-user.target

        (which worked fine on said VAIO to boot at the $ linux prompt)
      led to
        failure to connect to lvmetad, falling back to device scanning,
        whereby an endless disk scanning begun.

        I tried:

        1) Super grub2 disk: OK it led to clean boot but I found no way
        fix the problem.

        2) Accessing the X79 computer from said VAIO (both are on a
        equally allowed to manage everything but I was unable to fix

        3) From said VAIO:
         # systemctl enable lvm2-lvmetad.service

        OK, but it was lost on needed reboot.

        I never had to reinstall a debian amd64 but this time I am

        Thanks for any kind suggestion

    Have you enabled the daemon in lvm.conf? Look for "use_lvmetad".

    However, I think this should not be a problem. lvmetad is the LVM
    Metadata Daemon, which is primarily a caching daemon. If you have a
    of disks, or change your logical volumes frequently, the lvmetad
    speed up the varioud LVM commands. It is not required for normal
    and ~99% of people can ignore the "failure to connect" message.

        francesco pietra

    For more information, please reread.


  Visible links
  1. mailto:mailinglist@darac.org.uk

For more information, please reread.

Attachment: signature.asc
Description: PGP signature

Reply to: