[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: packages requiring ia32-libs ia32-libs-gtk



Many thanks for your suggestions !

Klaus,

I d/l the latest i386 package ('current') then after the package is loaded into the database (by dpkg -i) it still can not be configured, as expected, because:
 
/tmp r: dpkg --configure google-earth-stable
dpkg: dependency problems prevent configuration of google-earth-stable:
 google-earth-stable depends on lsb-core (>= 3.2).


I tried apt-get install -f but at that stage, it does:

The following packages will be REMOVED:
  alien binutils bsd-mailx build-essential chkrootkit cpp-4.4 cpp-4.5 cpp-4.6 cron
  debhelper dpkg-dev ed exim4-base exim4-daemon-light flashplugin-nonfree g++ g++-4.7
  gcc gcc-4.2 gcc-4.4 gcc-4.5 gcc-4.6 gcc-4.7 gedit gedit-plugins gir1.2-peas-1.0
  google-earth-stable:i386 hugin libpeas-1.0-0 libseed-gtk3-0 libstdc++6-4.7-dev
  linux-headers-2.6.39-2-amd64 linux-headers-3.2.0-2-amd64 linux-headers-3.2.0-4-amd64
  make misdn-source nvidia-kernel-source quilt texlive-binaries

which a bit too heavy, for me.

So i wonder how you (Klaus) did the trick ?

Goswin,

> 2) See if you can't get google-earth to accept lsb-core:amd64 instead
> or replace the dependency with the actual packages it needs (which can
> then be Multi-Arch: foreign).

Is there any file within the .deb package that specifies the lsb-core arch. I looked into the package with midnight commander (mc) but couldn't find anything. Or generally, how do i change the dependency ?







Reply to: