[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Network problem

here is the driver version in k3.1

root@astrotrain:/home/dean# modinfo atl1c
filename: /lib/modules/3.1.0-1-amd64/kernel/drivers/net/atl1c/atl1c.ko
license:        GPL
description:    Atheros 1000M Ethernet Network Driver
author:         Jie Yang <jie.yang@atheros.com>
srcversion:     6B5B83F39487C00C3BF2E83
alias:          pci:v00001969d00001083sv*sd*bc*sc*i*
alias:          pci:v00001969d00001073sv*sd*bc*sc*i*
alias:          pci:v00001969d00002062sv*sd*bc*sc*i*
alias:          pci:v00001969d00002060sv*sd*bc*sc*i*
alias:          pci:v00001969d00001062sv*sd*bc*sc*i*
alias:          pci:v00001969d00001063sv*sd*bc*sc*i*
intree:         Y
vermagic:       3.1.0-1-amd64 SMP mod_unload modversions

If the version is the same in your kernel, its very unlikely that a kernel update will help. There doesnt appear to be any specific module options, so thats not something that can be explored.

You can of course, email the driver author. They are almost always interested to know if a reproducible bug has been found.


On Tue, 27 Dec 2011 14:24:44 +0100, regexes wrote:

Thanks for the reply...

kernel: 2.6.32-5-amd64
Driver: atl1c

I tried unloading and loading the driver but it didn't work though.
I'll  try some of your other suggestions. Maybe I'll find something.


On Tue, 27 Dec 2011 12:59:46 +0100, Dean Hamstead
<dean@fragfest.com.au>  wrote:

The kernel may not be aware that something is wrong. Your email has garbled which driver is in use, could you please clarify and also which kernel version are you using?

Some steps i suggest are...

- see if traffic is leaving your machine (mirror ports, hubs or a cross over to another machine. then use tcpdump or wireshark)
- try unloading and loading the driver, does it work again?
- check what options are available for the driver, and play with any you might have
- update your kernel

some more exotic things to check...
- check that iptables isnt being triggered by something?
- it could be an irq conflict, especially if the card (or driver) doesnt play nicely with shared irqs. you may be able to clear the share by disabling an unused serial or parallel port - following from the above, you could change to polled rather than irq and see what happens. polling uses lots more cpu (ok thats an over simplification, it is better in some circumstances)
- maybe your dns lease is expiring?


On Tue, 27 Dec 2011 12:44:04 +0100, regexes wrote:
Hello everyone,

I just aquired a new Lenovo G770 laptop and am having a strange issue with
the Ethernet Controller.

Network connection works fine for a few minutes then dies. The interface is still configured though but it just stops working. There are no error
messages in dmesg either.

My router is not a problem. Access is granted and it does work to begin
with and the logs show nothing abnormal.

I've seen a few threads concering the G770 with Ubuntu but nothing that
addresses this problem.

Output of ifconfig -a

eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx
                  inet addr:xxx.xxx.xxx.xxx  Bcast:xxx.xxx.xxx.xxx
inet6 addr: xxxx::xxxx:xxxx:xxxx:xxxx/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:3983 errors:0 dropped:0 overruns:0 frame:0 TX packets:3139 errors:0 dropped:0 overruns:0 carrier:1
                  collisions:0 txqueuelen:1000
RX bytes:4773236 (4.5 MiB) TX bytes:457213 (446.4 KiB)

The output of lspic -v
01:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast
Ethernet (rev c1)
                Subsystem: Lenovo Device 3979
                Flags: bus master, fast devsel, latency 0, IRQ 27
Memory at d0500000 (64-bit, non-prefetchable) [size=256K]
                I/O ports at 2000 [size=128]
                Capabilities: [40] Power Management version 3
Capabilities: [48] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Capabilities: [58] Express Endpoint, MSI 00
                Capabilities: [6c] Vital Product Data
                Capabilities: [100] Advanced Error Reporting
                Capabilities: [180] Device Serial Number
                Kernel driver in use: atl101:00.0

Anybody have an idea what could be happening with the Eternet controller
and how I can fix it?

Another issue are the function keys. On my old Thinkpad, the
tpb package worked very well, however, that package isn't available on amd64. What other possibility is there to get the function keys to work?

Thanks for any help!

Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

Come play computer games with us at http://fragfest.com.au

Reply to: