[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libc6 and X11 seem not to work together

From: Hans-J. Ullrich <hans.ullrich@loop.de>
Date: Wed, Sep 30, 2009 at 03:47:39PM +0200
> Dear maintainers, 
> since the last upgrade (debian-amd64/sid) it is not more possible to start X. 
> It seems, libc6 is incompatible to the xserver-packages in debiansid
> Backtrace:
> 0: /usr/bin/X11/X(xorg_backtrace+0x26) [0x4edfe6]
> 1: /usr/bin/X11/X(xf86SigHandler+0x39) [0x483699]
> 2: /lib/libc.so.6 [0x7f7e17a41db0]               
> 3: /usr/bin/X11/X(DGAAvailable+0x39) [0x4823c9]  
> 4: /usr/bin/X11/X(xf86DiDGAInit+0x30) [0x4ae200] 
> 5: /usr/bin/X11/X(xf86CrtcScreenInit+0x10d) [0x4aafad]
> 6: /usr/lib/xorg/modules/drivers//radeon_drv.so [0x7f7e15e26a49]
> 7: /usr/bin/X11/X(AddScreen+0x1c6) [0x432ac6]                   
> 8: /usr/bin/X11/X(InitOutput+0x241) [0x46d361]                  
> 9: /usr/bin/X11/X(main+0x200) [0x4331d0]                        
> 10: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f7e17a2e5c6]     
> 11: /usr/bin/X11/X [0x432819]         
> For me it looks like Xorg gets a problem with the latest libc6-version from 
> sid. Can someone confirm this ? 
> Another info: It might not appear on every computer. Mine is working fine 
> (amd64 + Nvidia-driver), but the one from a friend (amd64 + ati-driver) causes 
> the message above.
> Should I file a bugreport?
I'm not sure about the exact backtrace (I'm at work now) but I see the
same after an upgrade on my laptop, which runs Unstable/i386 2 days ago.
A signal-11 when starting X. I'm using a pretty default debian install,
with gnome, the default drivers (no binary drivers). It's not helping
that my laptop uses network-manager to get the wireless network running,
which won't work when X doesn't come up :-{

It has a name, among the Voyani.
Lumina Arden. The light that burns.
You will feel its fire, Serra Diora.
	Michelle West - The Broken Crown

Reply to: