[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: forcedeth generates Invalid MAC address message

On Sunday 11 November 2007, Eugen Dedu wrote:
> Hi,
> The first byte of your MAC address is 1d, i.e. 00011101.  On
> http://en.wikipedia.org/wiki/Mac_address (the figure): if the last bit
> of the 1st byte is 1, then it is a multicast address, NOT a unicast one.
>   As such, it cannot be the "main" address of a NIC.  Maybe the address
> reading has a problem?  On some laptops, the MAC address is printed on
> the back side of the laptop.  Can you look at it?
> You can also use http://standards.ieee.org/regauth/oui/index.shtml to
> find out the enterprise which has built a NIC.
> Cheers,
> --
> Eugen Dedu
No luck on the MAC addresses being printed on the bottom.  I've tried to 
locate the chip on the IEEE website without luck.  It looks like the MAC 
address that is getting posted on both machines is in a reverse byte order.  
When I call up the MAC address on the Windows side of the computer the byte 
order is reversed.  As a result, the first three bytes of my MAC address are 
00-1B-38.  According to IEEE these MAC addresses are assigned to COMPAL 
Judging from what I am reading, Nvidia chips had issues with reporting their 
MAC addresses.  As a result, forcedeth swaps the bytes.  The board in the 
computer claims to be Nvidia, but the chip is registered to Compal.  In 
looking up the chipset in hardware for linux
I get pointed to a different driver for the NIC. (r8169)  But the kernel does 
not seem realize this during the boot process.  As a result, it calls 
forcedeth and forcedeth swaps the byte order.  I am baffled on how to 
override this selection.  I've already tried blacklisting forcedeth 
in /etc/modprobe.d/blacklist and adding r8169 into /etc/modules but it seems 
to load the forcedeth module regardless of the fact that it is blacklisted.  
I have also tried moving forcedeth.ko from the kernel/drivers/net/ directory 
but without luck.  forcedeth gets loaded as a module anyway.  This problem 
happens as soon as forcedeth tries to initialize the NIC.  I'm not certain 
what to try next.  Any suggestions?

Reply to: