[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: K8 Mainboards Linux compatibility list

Użytkownik Jo Shields <jo.shields@comlab.ox.ac.uk> napisał:
>tomek.fizyk@op.pl wrote:
>> Hi. You wrote that you have no problems with your MB with nForce3.
>> I have 2 questions.
>> I have also a MB with nForce3 and have some problems with the intel8x0
>> sound driver. (My MB is AsRock K8Upgrade-NF3).
>> My chipset's full name is nForce 3 250. The snd_intel8x0 does not see
>> the MIDI device. I know that the sound chip in the nForce3 250 has the
>> MIDI support - when I used windows some time ago the MIDI worked and
>> it was not any MIDI emultion but true MIDI device was detected by the
>> drivers. So is is because the snd_intel8x0 does not support MIDI (do you
>> have MIDI in support your system)?
>Sorry, but you're wrong here - basic AC97 codecs like the Realtek your 
>board probably uses has no real MIDI support.
>Just because it's shown in Windows, doesn't mean it isn't emulated - and 
>emulating MIDI in Linux is a chore (but possible, try reading the FAQ on 

hmm... I guess you're right... My sound chip is Realtek ALC850 and I've
checked and it turned out there is no hardware midi:(

>> The second problem is related to Debian AMD64 only - the problem was
>> not present on Debian i386 (do you use the Debian AMD64?).
>> The sound driver can be used only by one app at a time (for example
>> when I listen to music with xmms the KDE has no access to the sound
>> device; or when KDE uses the sound device (through aRts) no other app
>> has access to the sound device, etc). One of the apps ran in console
>> printed an error msg saying that there is no /dev/dsp-1 device.
>> I would like to know if these are general problems or if only I have them.
>> Tomek
>Again, you're wrong here. When accessing sound cards via OSS 
>(/dev/dsp*), only cards with hardware mixing support can accept multiple 
>sounds at once - regardless of architecture. The exception here is the 
>closed-source "nvsound" driver for use with NForce motherboards, which 
>emulates hardware support. At any rate, with the basic snd-intel8x0 
>driver, you cannot have multiple calls to /dev/dsp* devices. However, 
>via the newer ALSA devices (which you never address directly, but 
>technically live in /dev/snd/), it is possible to use software mixing 
>support, via a mechanism called "DMIX". On older versions of ALSA (e.g. 
>that included with Debian Stable), you need to configure DMIX by hand.

That's strange... I generaally use ALSA (in xmms, arts, etc.). But maby the
app I ran in the console used OSS (it was skype ran via chroot).
But as I wrote the problem is _only_ when I use Debian AMD64.
I have also Debian i386 installed and the same apps when running under
the i386 Debian they have no problems with sound.


Reply to: