[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Wolfenstein: E-T on debian amd64 with ATI X800 Pro gfx?

Jesper Nyholm Jensen wrote:
I would like to run Wolfenstein: Enemy Territory on my amd64 system,
as I had it running on my 32-bit debian before I upgraded to amd64. Is it at all possible?

Some words about my setup:

o HW: - AMD64 3200+,
    - ATI X800 Pro gfx card.
  o SW:
    - OS: debian amd64 unstable/sid,
    - Linux kernel:,
    - X: Xorg 7.0,
    - gfx driver: proprietary ATI binary driver v. 8.27.10 (kernel module compiled and loaded),
    - a 32-bit debian sid chroot,
    - Wolfenstein: E-T v. 2.60.

is working. I installed mplayer and some codecs and was able to view a .wmv-file.
Also, I installed firefox and a flash plugin and was able to view flash in firefox.

is working on amd64. I tried running 'ppracer' (on amd64, i.e. not in chroot) with and without
the driver loaded - it runs fast with and slow without. I also tried
installing and running 'ppracer' in my chroot, but it was slow, so it
seems 3D-acceleration is not working for my chroot.

Wolfenstein: Enemy Territory:
is not working, neither in amd64 nor in the 32-bit chroot. Here is the
output when run in chroot:
============================== ET output begin ===================== W: Failed to change to directory '/pack/fglrx/ati': No such file or
W: Falling back to directory '/'
I: [sid386 chroot] Running command: "et"
ET 2.60 linux-i386 Mar 10 2005
----- FS_Startup -----
Current search path:
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)

3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect

You are using software Mesa (no hardware acceleration)! Driver DLL used: libGL.so.1
If this is intentional, add
"+set r_allowSoftwareGL 1"
to the command line when starting the game.
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Received signal 11, exiting...

============================== ET output end =====================
Except for the first 3 lines the output is exactly the same in amd64.

Any ideas?
1) You need the ATI driver installed inside the chroot as well as outside it (as it provides replacement libGL files)

2) What does "ls -l /usr/lib/libGL.so.1" say?

3) what does "glxinfo | grep vendor" say?

Reply to: