[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

No sound on etch when using video players

Hash: SHA1

I have a problem with etch on AMD64 - no sound on any video player.

I am running a 2.6.15 kernel.

My sound card is recognised; cat /proc/asound/cards shows the following:

0 [CK804          ]: NFORCE - NVidia CK804
                     NVidia CK804 with ALC850 at 0xd3103000, irq 17
1 [UART           ]: MPU-401 UART - MPU-401 UART
                     MPU-401 UART at 0x330, irq 10
I can play audio CDs using the KDE player kscd but the gnome player and
xmms do not work.

No matter which video player I use - totem, mplayer or kaffeine - I
get no sound.

With mplayer, the following output is seen:

Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 2.0 (stereo)  48000 Hz  448.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)

My config file for mplayer has the audio option set to alsa.

I have tried using esd after changing the option but to no avail.

When I run totem or kaffaine from a terminal, there is no output
relating to sound. The sound controls are active in both.

Any help in debugging this would be greatly appreciated.

- -- 
Sam Varghese
Program testing can best show the presence of errors but never their absence.
- - Edsger Wybe Dijkstra
My PGP key: http://www.gnubies.com/encryption/sign.txt
Version: GnuPG v1.4.3 (GNU/Linux)


Reply to: