[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot install a bootloader

Hi Steffen,

Thanks for your reply. Only I'm not sure what to do now... I've chrooted to /target and tried to install grub again, still the same error. The mtab and device.map look correct to me.

Could you give me another hint?



Steffen Grunewald schreef:
On Tue, Jun 20, 2006 at 11:07:05AM +0200, Dirk Bonenkamp - Bean IT wrote:
Hi All,

I've trouble installing the bootloader (both grub and lilo fail). I'm 
using the netinstall cd-image to install. My first idea was a problem 
with my RAID controller (Adaptec 2020ZCR, running a 4 disc raid 5 array) 
but it even fails to install a bootloader to a floppy disc. So I think 
it's a general problem, instead of a hardware problem.

It always returns the same error message:

The file /boot/grub/stage1 not read correctly.

The thing I found out is that the new / filesystem is still mounted 
under /target, but I guess this is normal while installing...? (never 
bothered to look, since it always works out fine).
I've seen this error message a few times.
grub must be installed from a chroot environment (which should be true
in your case).
grub must find a *correct* mtab to resolve hard disk partitions.
(it's a bit tricky since the /proc/mounts trick appears not to work)
A leftover device.map may confuse it as well.



Reply to: