[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: system clock running 4% fast


On Mon, 2006-03-20 at 10:13 +0000, Andrew Schulman wrote:
> Since I built my new amd64 host, my system clock is borked.  It runs about
> 4% fast-- gaining an hour a day.  This is way to much gain for ntpd to keep
> up with.  To compensate I've had to set adjtimex --tick 9600, which
> approximately corrects for the drift.
> This would be tolerable, except that the drift rate isn't constant.  It's
> all over the place.  Right after I boot it's stable at about -50 PPM, but
> then after a few hours it suddenly goes nuts.  Look at the adjustments
> ntpdate has to make when I run it once a minute:
> No wonder ntpd can't keep up.  The drift rate is all over the place.
> I'm running a custom 64-bit kernel 2.6.15.  CPU is Athlon64 X2 4200+,
> chipset is nForce4.
> Many people are reporting problems related to time with the 2.6.15 kernel on
> amd64, e.g.
> http://bugzilla.kernel.org/show_bug.cgi?id=3927
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=354995
> http://www.ussg.iu.edu/hypermail/linux/kernel/0410.1/1505.html
> A search for "amd64 linux clock" turns them up.  However, 80% or more of the
> discussion seems to be about the "AMD/ATI bug", which applies to the
> combination of AMD processors with some ATI chipsets (not sure which one). I
> don't have an ATI chipset.  Still, I've tried all of the following boot
> parameters that people have recommended for this problem:
> disable_timer_pin_1 (my host won't boot)
> no_timer_check
> noapic acpi=off
> clock=pmtmr notsc
> I also disabled CPU frequency spread spectrum in the BIOS.  The result is
> always the same-- the clock is stable after I boot, but a few hours later it
> goes nuts again.
> Help!  How can I fix my system clock?  Do I a hardware problem?  How can I
> tell?  Any help would be greatly appreciated.

I can remember a story about a Sparc/Solaris system that was the time
server for a network but it kept very, very bad time.  It turned out it
was also terminal (RS232 type) server as well.  In Solaris the serial
interrupt ran at a higher priority than the clock tick so it was losing
a number of clock ticks every day - thus the poor time.

I was wondering if something simular was happening to you?  Have you got
some hardware/driver that is causing the system to miss clock

Hope this helps

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: