[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Confirm needed: python2.3 (thus lots of other stuff) uninstallable from etch?

On Sun, Feb 05, 2006 at 06:12:51AM +0000, cmetzler@speakeasy.net wrote:
> Can anyone else confirm this:
> } stax:/etc/apt# apt-get install python2.3
> } Reading package lists... Done
> } Building dependency tree... Done
> } Package python2.3 is not available, but is referred to by another package.
> } This may mean that the package is missing, has been obsoleted, or
> } is only available from another source
> } However the following packages replace it:
> }   python
> } E: Package python2.3 has no installation candidate
> }
> } The following packages have unmet dependencies.
> }   python: Depends: python2.3 (>= 2.3.5-1) but it is not installable
> } E: Broken packages
> Because of this, tons of stuff, from reportbug to GNOME, is uninstallable
> for me.  My sources.list mirrors are:
> } deb http://debian.csail.mit.edu/debian-amd64/debian/ etch main contrib
> } deb-src http://debian.csail.mit.edu/debian-amd64/debian/ etch main contrib
> }
> } deb http://mirror.espri.arizona.edu/debian-amd64/debian/ etch main contrib
> } deb-src http://mirror.espri.arizona.edu/debian-amd64/debian/ etch main contrib
> Can anyone else confirm this?
> Thanks,
> -c

Yes, the 'Packages' of your mirror doesn't seem to have 'python2.3' and
'python' depends on that.

It seems to be one those "old version doesn't exist anymore, but the
new version has not entered testing (or your mirror) yet" situations.

The actual file (both old and new) seem to be in the pool, so maybe the
Packages file of your mirror is out of date:


My mirror has the newer version, so you might want to try a different
mirror, or wait until it gets into your mirror.

I use ftp://ftp.nl.debian.org/debian-amd64/debian/

:r ~/.signature

Attachment: signature.asc
Description: Digital signature

Reply to: