[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: amd-64 vs Pure-64

Jonas Meurer wrote:
> On 27/09/2005 Marc F. Clemente wrote:
>>>Where might I find the sources and patches from which you compiled
>>>your version of OOo2?
>>My sources:
>>deb-src http://mclemente.net/debian/ ./
>>The only changes I made were to the debian/rules file and to the
>>vbarange.cxx and vbarange.hxx files.
> hello,
> i just fetched ooo2 sources from experimental (1.9.125-1), and tried to
> build them on amd64 with your patch.
> unfortunately the build process breaks after an hour with the following
> error:
> ---snip---
> [...]
> make[2]: Making `all' in `data'
> make[3]: Entering directory `/home/jonas/devel/openoffice.org2/openoffice.org2-1.9.125/ooo-build/build/src680-m125/icu/unxlngx4.pro/misc/build/icu/source/data' > /bin/sh ../mkinstalldirs ../data/out ../data/out/build ../test/testdata/out ../test/testdata/out/build
> mkdir ../data/out
> mkdir ../data/out/build
> mkdir ../test/testdata/out
> mkdir ../test/testdata/out/build
> ICU_DATA=../data/out/build LD_LIBRARY_PATH=../common:../i18n:../tools/toolutil:../layout:../layoutex:../extra/ustdio:../tools/ctestfw:../data/out:../data:../stubdata/:$LD_LIBRARY_PATH ../tools/genpname/genpname -d ../data/out/build > Inconsistency detected by ld.so: dl-minimal.c: 137: realloc: Assertion `new == ptr' failed!
> make[3]: *** [../data/out/build/icudt26l_pnames.icu] Error 127
> make[3]: Leaving directory `/home/jonas/devel/openoffice.org2/openoffice.org2-1.9.125/ooo-build/build/src680-m125/icu/unxlngx4.pro/misc/build/icu/source/data'
> make[2]: *** [all-recursive] Error 2
> make[2]: Leaving directory `/home/jonas/devel/openoffice.org2/openoffice.org2-1.9.125/ooo-build/build/src680-m125/icu/unxlngx4.pro/misc/build/icu/source' > dmake: Error code 2, while making './unxlngx4.pro/misc/build/so_built_so_icu'
> '---* tg_merge.mk *---'
> ERROR: Error 65280 occurred while making /home/jonas/devel/openoffice.org2/openoffice.org2-1.9.125/ooo-build/build/src680-m125/icu
> make[1]: *** [stamp/build] Error 1
> make[1]: Leaving directory `/home/jonas/devel/openoffice.org2/openoffice.org2-1.9.125/ooo-build'
> make: *** [debian/stampdir/build] Error 2
> ---snip---
> just wanted to report that, maybe it's an already known issue.
> ...
>  jonas

Sweetness. I have been able to successfully compile (and run, haven't done anything serious) openoffice.org2 on my pure amd64 system. The build to all day (maybe 6 hours) and required patching a header and source file and exporting LD_PRELOAD=/lib/libc.so.6 (which fixes the error encountered above). I also had to add amd64 to the debian/control file.

I cannot comment on the stability of ooo2 on amd64 but from what I read it appears that it is still not 64 bit clean which in layman's terms means it is going to SEGFAULT/crash all over the place. I will keep you guys updated on my findings. (I feel like a gentoo ricer now...)
Matthew A. Nicholson

Reply to: