[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SID xwindows

I've been fighting with this problem for the last few days and now it has taken a turn in the direction of SID X packages.

When I couldn't get tightvncserver to work, I thought it might be that package, so I installed realvncerver. (everything managed through official mirror with apt-get)

Well, it still don't work. The Xvnc server crashes everytime it starts. I start it with % realvncserver and then grep the process and it isn't there. .xsession-errors shows the following:

Xsession: X session started for bill at Mon Sep  5 14:05:40 CST 2005
xrdb: Connection refused
xrdb: Can't open display ':20'

I'm wondering if it might have something to do with xhost or xauth. the xhost command times out and the xauth wont generate any cookies because it can't open the display.

bill@amd64-1:~$ export DISPLAY=amd64-1:0.0
bill@amd64-1:~$ echo $DISPLAY
bill@amd64-1:~$ xauth generate amd64-1:0
xauth: (argv):1:  unable to open display "amd64-1:0".

So, I go to the console, log in as regular user, start up X, and it starts fine. Open a konsole window, type xclock, and it tells me "Can't open display". What kind of problem is it that can't open a display in the same local desktop environment where it is already running? I tried setting the DISPLAY var in the konsole window to none, localhost, name of the system (amd64-1) all to no avail.

After all that, I tried installing the X11 stuff from X.org; again with apt-get. I think I may have made things worse however.

Does anyone know of any X bugs in the standard SID packages??


Reply to: