[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing amd64 on Adaptec 2015S (SmartRAID V) with dpt_i2o

Lennart Sorensen wrote:
On Wed, Aug 31, 2005 at 03:21:30PM -0700, Neil Gunton wrote:

I just built a server which has dual Opteron 265, 4GB RAM, Adaptec 2015S zero-channel RAID controller and 4 x Ultra320 10k SCSI drives.

I am having a problem installing Debian amd64, because of the 2015S card. This requires the dpt_i2o driver, which is not included by default in Debian amd64.

Well last I looked (2.6.12 kernel), the dpt_i2o driver was listed
explicitly as not 64bit compatible and couldn't be selected on any 64bit

I have replaced the dpt_i2o files with the new ones provided by Adaptec, but I cannot figure out how to enable the module for selection under x86_64. I tried adding a line to arch/x86_64/configs/defconfig, but this still doesn't make the module come up in the list when I do a 'make menuconfig'. Do you have any idea how to enable the module? Where is the kernel config being told specifically not to include this? I did a grep for DPT_I2O but I couldn't find anything else.

I don't know what i2o_blocks is, but I did include the i2o drivers in my

Sorry for the typo, I meant i2o_block

2.6.12 based sarge amd64 netinst image.  Feel free to try that one if
you wish.  I have i2o_block, i2o_config, i2o_core, i2o_proc and i2o_scsi
included.  May have to manually modprobe them from console 2, since I
have no idea I the discover data knows to try those for your controller.


I tried this, and it looked promising at first. I was able to modprobe i2o_block and then partition the hard drives, but it failed later when trying to install the kernel, with a message something like this:

/usr/bin/mkinitrd: device /dev/i2o/hda/part3 is not a block device
Failed to create initrd image

In any case, I noticed that the installer was attempting to install linux-image-2.6.12-1-amd64-generic, which makes me nervous - surely this would not have the dpt_i2o driver, and so I would not be able to boot into the system after install?

I had an idea to compile the kernel with dpt_i2o under CentOS, since that is working currently under x86_64 and i2o_block. If I was able to include the new dpt_i2o driver in this kernel, and then replaced the one on the stock Debian netinstall disk with the new one, should that work? Would it be able then to see the 2015S using the dpt_i2o module? But then, if the installer still wants to put in a stock kernel then that's no good. I suppose I could then boot into linux rescue and replace the stock kernel with the custom one off the install disk. Might that work?

I managed to get hold of Mark Salyzyn at Adaptec, and he sent me source code for the dpt_i2o driver which he tells me should work in 64-bit mode. I could presumably build this into a custom kernel. But I don't know how to do this while installing Debian from scratch.

That would be a problem yes.  If I knew it would work, I would be
willing to add the driver to my installer image's kernel.
Could you send me the updated driver to have a look at?

Yes, I will send this in a separate email.

Thanks for your help!


Reply to: