[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Mkinitrd problems

Hello list.

Yesterdey I spotted two problems with mkinitrd:

$Id: mkinitrd,v 1.201 2004/05/16 22:00:48 herbert Exp $

from Sid with up to date updates.

1. In /usr/sbin/mkinitrd script is (or was) with "find" in line 601

There is:

 find /proc/scsi -type d -mindepth 1 -maxdepth 1 \

and should be:

 find /proc/scsi -mindepth 1 -maxdepth 1 -type d \

If not "find" shouts about sequence of options and arguments.

2. mkinitrd don't produce output. 

I run:

mkinitrd -o "image_name" "version" 

and there is no output file.

Critical bug?

I run minitrd with option "-k" and build initrd image with mkcramfs.

Anybody else can confirm those errors? Or they are just on my system.

Grzegorz Andrelczyk   | Wszechświat - kilka praktycznych informacji:
gandrel@gmx.net       | 1.Obszar: nieskończony; 2. Import: brak; 
www.nie-panikuj.w.pl  | 3.Eksport: brak; 4.Ludność: brak; 5.Waluta: brak;
                      | 6.Sztuka: brak; 7.Seks: brak.

Reply to: