[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: nforce4, Harddisk SATA, DVD-Burner ATAPI: How can I keep ide-scsi from loading?

On Mon, May 16, 2005 at 06:43:00PM +0200, K. Gysin wrote:
> Hi all,
> I have the following problem:
> My cd-burner is the only device on ide (currently /dev/sr0 over
> ide-scsi), the harddisks are on SATA (/dev/sda, /dev/sdb).
> I cannot burn CD's with more than 9x (because of DMA bandwith
> limitations (according to cdrecord))
> Now, I know that ide-scsi is supposed to be broken in 2.6.x kernels, and
> I should not expect it to work. Indeed I can boot a knoppix cd (kernel
> 2.6.11) and it does not load any scsi modules, while the disks and the
> burner work as expected. I do however not know if some of the modules
> there are directly compiled into the kernel.
> uname -a
> Linux Nasqueron.wattstrasse.ch 2.6.12-rc3-050427 #2 Wed Apr 27 20:04:59
> CEST 2005 x86_64 GNU/Linux

Is this a custom built kernel or a standard debian kernel?

Debian makes ide-scsi a module.  If you built your own, you might not
have made it a module.

> Kernel 2.6.11 showed the same behavior.
> I have tried almost everything to get rid of the ide-scsi module:
> - rmmod ide-scsi gives a kernel oops
> - ide-scsi is not noted anywhere in /etc/modprobe.d/    
>   or /etc/modules.conf

And /etc/modules ?

> - rename the ide-scsi.ko file: the ide-scsi module still gets loaded!

Did that exist in the 

> - remake the kernel without the ide-scsi module: kernel panic upon boot
>   because it could not find the root device (which is on SATA)

So change root=/dev/sda1 or whatever your sata controller uses.  Make
sure you have the sata controller enabled in the kernel config, and not
some ide interface driver instead.

Which chipset is this for?

> So, it seems that somehow the SATA driver is connected to the ide-scsi
> driver? This would explain why all the scsi modules are loaded...

That should only be the case if the sata driver isn't a libata driver.

> I also think it very strange that it seems to recognize my burner
> as /dev/hda, and then relinks it somehow to /dev/sr0 (if you check the
> dmesg output below)???

That is how ide-scsi works.

Perhaps include your .config from the kernel build.

Try using a standard debian kernel build and see if it gets it right.
You may have to tell it the right driver to load in
/etc/mkinitrd/modules like sata_sil or ata_piix or sata_via since it
will detect what it is currently using which may not be what you should
be using.

I have both a via and an intel chipset system using sata drives and a
plain ide dvd burner and I don't have ide-scsi enabled and everything
works perfectly with dma on and all that.  That is the state after
installing sarge using linux26.  I got the same result on the via using
the sarge pure64 installer with the default kernel.

Len Sorensen

Reply to: