[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Netinstall fails to detect SATA disk.


I had this kind of behavior (sata disk detected but not responding), with netinst and 2.6.10. My solution was in the BIOS. I had to disable all kind of ide detection on empty slots and since then it worked perfectly.

I explain: I have an ide disk master on ide0 (no slave), an ide DVD-ROM master on ide1 (no slave), one sata disk on ide2 and no sata disk on ide3. If I prevent the bios from detecting anyway on ide0/slave, ide1/slave and ide3, all is fine !

Hope this helps,


Le 1 févr. 05, à 04:01, Dale E. Martin a écrit :

I don't know why it is not working with this debian-installer. It seems to me that the modules sata_nv and libata are loaded, but maybe I need

A bug in kernel 2.6.[789] prevent disk from responding if attached to
the nforce SATA port. You've been bitten by this bug.
Symptoms are : quering the SATA port finds something, but the query of
the diks times out.

2.6.10 works ok.

I'm typing this on a Shuttle SN95G5 running 2.6.8 with (only) an SATA hard drive. I don't believe I did anything special - the SATA just worked...
(I used the sid-amd64-netinst.iso image.)

Let me know if there's any other info I can provide that would be of help.

Take care,
Dale E. Martin - dale@the-martins.org

To UNSUBSCRIBE, email to debian-amd64-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Attachment: PGP.sig
Description: =?ISO-8859-1?Q?Ceci_est_une_signature_=E9lectronique_PGP?=

Reply to: