[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

CardBus problem


I'm having problems with CardBus on my ASUS A2526KUH.
The pc has
0000:02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
0000:02:01.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)

but I can't have it work properly.
Yenta_socket module loads correctly, 
#cardctl status
Socket 1:
  3.3V CardBus card
  function 0: [ready]

seems ok, but lspci then doesn't show the connected card!
I tried different cards, also an old 3com ethernet, nothing happens.
I'm using custom 2.6.9 kernel, but I tried 2.6.10rc2 custom and 2.6.8
debian with the same result.

The CardBus works, I tried it on Windows. 
But I know it works also because I tried Knoppix3.6 with 2.4 kernel
and finally I managed to see the connected card in lspci (knoppix with
2.6 didn't work!!).
It mustn't be a Debian-kernel's problem because Knoppix uses vanilla kernel. 

I'd like to know of any of you have the same Cardbus (or pc) and if it works.
I've seen, googling around, that Ricoh bus is very commonnly used on
laptops, so I can't figure out why I am the only one experiencing this

any help welcome
debian-amd64 (installed pretty fine...)

Reply to: