[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation report: Abit KV8 Pro / Athlon 64 3000+ / SATA

A couple of days ago I completed the installation of pure64 on an Abit KV8 Pro. I could say the whole process was almost easy. Here is a detailed report.

M/B:  Abit KV8 Pro (VIA K8T800Pro+/VT8237)
CPU: Athlon 64 3000+
H/D :  Hitachi Deskstar 160G SATA
VGA: MSI GeForce FX 5700LE
On board sound: AC 97
On board gigabit lan: VIA VT6122 ... Failed and disabled. Using a Realtech

netinst from: image http://debian-amd64.alioth.debian.org/install-images/sid-amd64-netinst.iso downloaded on October 18th.
mirror used: ftp://ftp.de.debian.org/debian-amd64/pure64/ sid main
partitions (all reiserfs):
hda1 (10G): /
hda2 (1G): swap
hda3 (70G): /home
hda4 (76G): /I don't know what to do with it yet

Installation highlights:

* Boot from cd and base system installation:
- Linux26 led to non existent kernel image. Later I discovered that the only available kernel is 2.6.8. - VIA VT6122 on board gigabit lan was not detected. A quick google revealed that there is no support yet. Replaced with a realteck. WARNING: I had to disable on board lan from the BIOS, otherwise the installer was failing with an error (sorry don't remember the message)
- No more problems. Base system installation perfect.

* Package selection
- With sarge I was used to start with a few task selections. Here there were not any tasks. - I finally did an apt-get install `cat my_favorite_package_list` and got my system up and running - And because the process took some days, I did an apt-get upgrade/dist-upgrade, which worked fine too.

* nvidia driver
I had 2 issues with this.

a. The fresh kernel (2.6.8-9) that was downloaded after the upgrade, turned out to be compiled with gcc-3.4. I didn't expecting this, although the howto says something about it, because there is a Debian version named gcc-3.4 and it was not the one I had installed. After downloading gcc-3.4 and setting 'export CC=gcc-3.4' the nvidia installer compiled the modules correctly.

b. nvidia installer is coping 32 bit modules over 64 bit modules. Just before it asks to copy them, switch to a console and grab a copy of the /tmp/somerandomname directory. Ignore all installer errors and when it finishes, copy the lib64 modules (form your tmp copy) to /usr/X11R6/lib/modules/drivers/

Works fine with a usb memory card

* Sound
Works ok with mpg123 and kde.

Working with it:
I am using this box as a development workstation and not (yet) as my primary desktop. After a week running mostly development tools I really like it. Excellent performance, and pretty good stability. All the development libraries that I use (gtkmm-2.x, gtkglextmm-1.x, commoncpp2, ode) worked fine. commoncpp2 may have a problem, but I am not sure yet. Kde, konsole, kdevlop, konqueror, kmail are working fine. kdevelop3 crashed 2 or three times, but it crashes on my i386 sarge too. Today I installed apache2, php & mysql. They seem ok, but I have not used them at all.

Missing support for VIA VT6122 gigabit lan, but you can get a realtech for 5 euros.
Very easy installation (just disable on board Ethernet)
The howto needs a little more work since it is confusing at some points.
On the other hand the mailing list is excellent. Thank you people!

Reply to: