[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Apache 2.0.50-8 upgrade breaks WebDAV (?)

Hello Philipp--

2.0.50-7 was definitely working for me.  I don't recall if it was -6 or older that had an issue with DAV just not working at all, but -7 was definitely working well.

However, on upgrading to 2.0.50-8, that no longer appears to be the case.

Hmmmm, I just did a quick little "ldd" survey:

# ldd /usr/lib/apache2/modules/mod_dav.so
        libdl.so.2 => /lib/libdl.so.2 (0x0000002a95679000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x0000002a9577d000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x0000002a9589f000)
        libdb-4.2.so => /usr/lib/libdb-4.2.so (0x0000002a959d2000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0000002a95bb1000)
        libc.so.6 => /lib/libc.so.6 (0x0000002a95d46000)
        /lib64/ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2 (0x000000552aaaa000)

# ldd /usr/lib/apache2/modules/mod_dav_svn.so | grep libapr
        libaprutil-0.so.0 => /usr/lib/libaprutil-0.so.0 (0x0000002a95ec0000)
        libapr-0.so.0 => /usr/lib/libapr-0.so.0 (0x0000002a96520000)

(the result list for the latter is much larger, hence the grep)

Since ap_register_provider is in libapr-0 (if memory serves), is this a problem?

It's been a long time since I debugged libs and compiled code (doing mostly sql/python/php/etc lately), so forgive my slowness on the uptake...


On Fri, 2004-08-13 at 06:32, Philipp Frauenfelder wrote:
Hi Dan

Apache 2.0.50-7 from
worked for me (with svn / WebDAV).

Philipp      | work: pfrauenf@math.ethz.ch  +41 44 632 60 38
Frauenfelder | home: pfrauenf@debian.org    +41 44 862 73 14
[PGP]        | http://www.math.ethz.ch/~pfrauenf/
Proudly running Debian GNU/Linux. See http://www.debian.org/

Reply to: