[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Apache 2.0.50-8 upgrade breaks WebDAV (?)

First-time post... I've had my dual Opteron/Tyan system running for a bit over a month with very little trouble (a general "you guys rock" to the amd64 porters).

I upgraded to Apache 2.0.50-8 prefork two days ago and where before I had the subversion+apache stuff working great (with WebDAV and the svn apache2 modules), I now get this:

# /etc/init.d/apache2 start
Starting web server: Apache2Syntax error on line 1 of /etc/apache2/mods-enabled/dav.load:
Cannot load /usr/lib/apache2/modules/mod_dav.so into server: /usr/lib/apache2/modules/mod_dav.so: undefined symbol: ap_register_provider

# cat /etc/apache2/mods-available/dav.load
LoadModule dav_module /usr/lib/apache2/modules/mod_dav.so

I've searched around a bit since this upgrade went south and haven't seen anyone with a similar problem, and I don't quite have any idea where to start.  Excuse me ahead of time for not providing enough info here... I'm not quite sure what will be useful (anyone who wants to chime in, I'll post whatever info needed).

Am I the only one getting this?

Thanks for any help or even a push in the right direction.

Dan Hugo

Reply to: