[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debootstrap of pure64

On Sat, Apr 17, 2004 at 10:27:39PM +0200, Kurt Roeckx wrote:
> I've been able to set up all packages that are needed to do a
> debootstrap of pure64.
> To do it set up a partition or something for pure64, I'll call it
> /pure64 here.
> Because some symlinks are missing in the packages you'll first
> need to symlink lib64 to lib:
> cd /pure64
> mkdir lib
> ln -s lib lib64
> mkdir usr
> cd usr
> mkdir lib
> ln -s lib lib64
> When that is done you can run debootstrap like this:
> debootstrap --arch amd64 --exclude=klogd,sysklogd,modutils sid /pure64 ftp://bytekeeper.as28747.net/amd64/jgoerzen/amd64
> klogd and sysklogd are missing because I'm currently unable to
> compile them, modutils because it doesn't support a 2.6 kernel
> and you just use module-init-tools.
> Kurt

When I follow these directions, with debootstrap, i get:

~# debootstrap --arch amd64 --exclude=klogd,sysklogd,modutils sid /chroots/pure64 ftp://bytekeeper.as28747.net/amd64/jgoerzen/amd64
I: Validating debootstrap.invalid_dists_sid_Release
E: Invalid Release file, no valid components

With cdebootstrap, i get:

~# cdebootstrap -a amd64 --download-only sid /chroots/pure64
I: Download indices...
P: Downloading dists/sid/Release
P: Parsing debootstrap.invalid_dists_sid_Release
P: Validating debootstrap.invalid_dists_sid_main_binary-amd64_Packages
P: Parsing debootstrap.invalid_dists_sid_main_binary-amd64_Packages
E: INTERNAL ERROR: can't find package!
package sysklogd don't exists
Segmentation fault

Trying to find an environment suitable for building 64 bit postgres, no
luck thus far.

TJ Vanderpoel GCIA,GCIH

Reply to: