[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Issues with kernel building

I actually worked out

It was because I didnt compile in IA32 Emulation

Which mean my kernel wasent allowing 32 bit bins for run :(


Jonathan Molyneux

Head Unix Administrator &
National Network Director
Australian Pro Gaming

Head Network Administrator
Leecom Technologies Pty. Ltd. t/a Web Lounge


Xavier Hienne wrote:

Jonathan wrote:

After following the howto @ http://alioth.debian.org/docman/view.php/1314/21/debian-amd64-howto.html

I was able to build a 2.6.1 or 2.6.2-rc2-bk1 monolithic kernel

And have gotten it working rather well

The problem I'm having is with a modular kernel

I cant seem to get a modular kernel to load

Without this error message occurring on boot

"request_module: runaway loop modprobe binfmt-464c"

IIRC, I ran into a similar problem. This was due to the fact that, to load modules, another module was necessary (System V IPC in my case), thus causing an endless loop.

binfmt-464c is ELF. The solution is to include ELF support into the kernel, not as module (General Setup -> Kernel Support for ELF binaries)

The second modular kernel

Is always build in the chroot using make menuconfig, make bzImage, make modules

The installation of the bzImage is done outside of the chroot with the make modules_install

You can do your modules_install in the chroot with the command below :

# export UNAME_MACHINE="x86_64"
# make modules_install

Or simply :
# UNAME_MACHINE="x86_64" make modules_install

UNAME_MACHINE allows bi-arch depmod to work correctly. It tells depmod which architecture your modules are compiled for.

I have setup the System.map as well into /boot

I?m unable to use make-dpkg to build kernel's due to error's

What errors ?

Has anyone had success there ?

I never tried make-dpkg with a 64 bit kernel. Here are some suggestions to make it work : execute the following commands before make-kpkg
# function make() { /usr/bin/make ARCH="x86_64" HOSTCC="gcc -m32" "$@"; }
# export -f make
# export UNAME_MACHINE="x86_64"

Just a guess, but it's worth to give it a try. Let us know if it works.


Reply to: