[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unversioned symbols when building kernel package

Hi Adrian,

On 04.01.23 22:15, John Paul Adrian Glaubitz wrote:

I just tried to build the Debian kernel package for alpha which fails with:

debian/bin/buildcheck.py debian/build/build_alpha_none_alpha-generic alpha none alpha-generic
ABI is not completely versioned!  Refusing to continue.

Unversioned symbols:
strcat                                           module: vmlinux, version: 0x00000000, export: EXPORT_SYMBOL strcpy                                           module: vmlinux, version: 0x00000000, export: EXPORT_SYMBOL strncat                                          module: vmlinux, version: 0x00000000, export: EXPORT_SYMBOL strncpy                                          module: vmlinux, version: 0x00000000, export: EXPORT_SYMBOL
Can't read ABI reference.  ABI not checked!
make[2]: *** [debian/rules.real:218: debian/stamps/build_alpha_none_alpha-generic] Error 1
make[2]: Leaving directory '/<<PKGBUILDDIR>>'
make[1]: *** [debian/rules.gen:426: build-arch_alpha_none_alpha-generic_real] Error 2
make[1]: Leaving directory '/<<PKGBUILDDIR>>'
make: *** [debian/rules:39: build-arch] Error 2
dpkg-buildpackage: error: debian/rules binary-arch subprocess returned exit status 2

According to this comment by Ben [1], this is an issue that is trivially fixed by adding the appropriate header to arch/$ARCH/include/asm-prototypes.h. However, looking at the header file, "#include <asm/string.h>" is already present so I'm not sure what else we're missing.

Indeed, and that file ([1]) wasn't touched in 5 years. I wonder if that then is not an error of the Debian build scripts.

[1]: https://github.com/torvalds/linux/blob/master/arch/alpha/include/asm/string.h

BTW the same error is already present for 5.19.6-1 - the build ran on 2022-09-18. Maybe the error corresponds with a change in the Debian linux repo ([3]) before that date.

[2]: https://buildd.debian.org/status/fetch.php?pkg=linux&arch=alpha&ver=5.19.6-1&stamp=1663530012&raw=0)

[3]: https://salsa.debian.org/kernel-team/linux

Looking at [4] the message "Can't read ABI reference." could indicate a missing file - filename is defined in line 51 ([5]) and `/debian/abi/` does not exist in [3].

[4]: https://salsa.debian.org/kernel-team/linux/-/blob/master/debian/bin/buildcheck.py#L54-L72

[5]: https://salsa.debian.org/kernel-team/linux/-/blob/master/debian/bin/buildcheck.py#L51


Reply to: