[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Booting Debian in qemu-system-alpha

On 1/24/20 6:16 AM, John Paul Adrian Glaubitz wrote:
> Hi!
> Has anyone had any success recently booting Debian on qemu-system-alpha?
> I just built qemu-system using the alpha-softmmu target from git and tried
> to run Debian's Alpha port but the output hangs very early:
> root@nofan:/local_scratch/alpha-system> ./qemu-system-alpha -m 512 -nographic -drive file=disk.img,media=disk,format=raw,index=0 -L pc-bios/ -kernel vmlinux -append ‘console=ttyS0’ -initrd initrd.gz -net nic -net user -drive file=debian-10.0-alpha-NETINST-1.iso,if=ide,media=cdrom
> PCI: 00:00:0 class 0300 id 1013:00b8
> PCI:   region 0: 10000000
> PCI:   region 1: 12000000
> PCI: 00:01:0 class 0200 id 8086:100e
> PCI:   region 0: 12020000
> PCI:   region 1: 0000c000
> PCI: 00:02:0 class 0101 id 1095:0646
> PCI:   region 0: 0000c040
> PCI:   region 1: 0000c048
> PCI:   region 3: 0000c04c

Works for me, from this morning's git (ba2ed84fe6a7).  I certainly get all the
way to the "Select a language" screen of the installer.

Oh.  Hah!  I just tried again, cutting and pasting your command-line.  You've
got unicode quotes, not ascii ' (\x27).  That gets passed through to the kernel
as-is and prevents console=ttyS0 from being parsed properly.

So the kernel output simply isn't going where you thought, and in this case,
nowhere at all.


Reply to: