[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian kernel boot failure on Alpha [was Re: systemd FTBFS]

On Sat, Mar 04, 2017 at 12:32:30AM +0100, John Paul Adrian Glaubitz wrote:
> On 03/04/2017 12:30 AM, Michael Cree wrote:
> > And the Debian kernel still doesn't boot on my XP1000.  As soon as
> > SRM transfers control to the kernel it falls back to SRM with a boot
> > failure message.
> Is there any sort of error message? Can you provide all messages from
> the kernel from the boot loader throughout the drop back to SRM
> console?

Interestingly it only fails on my XP1000 (DP264 variant Alpha).  Just
tried booting Electro (Titan variant Alpha) with the Debian kernel and
it came up fine.

On the XP1000 we get the messages:

aboot: starting kernel vmlinuz with arguments ...

halted CPU 0
halt code = 5
HALT instruction executed
PC = fffffc000102d800
boot failure

and then we are back in the SRM.

Given that a HALT instruction is executed I am guessing the kernel
panicked very early on.  The kernel symbols in the region of the PC

fffffc000102d700 t el_process_regatta_subpacket
fffffc000102d810 T privateer_machine_check
fffffc000102d8f0 t marvel_process_680_frame

and el_process_regatta_subpacket is in ./arch/alpha/kernel/err_titan.c.

On a quick inspection I am not sure what that function is doing, and
I am not sure why code intended for Titan variant Alphas is being
run on DP264.  I thought the kernel read the HWPRB from SRM very
early on and from that knows what hardware it is running on.


Reply to: