[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: UP2000 plus SRM update

Toshinao Ishii wrote [in Wed, 29 Aug 2001 18:27:16 +0900]:

I have problem of updating srm on my UP2000plus based machine.
The current version of SRM is A5.8-65.

What I did and what's happend was following. I prepared a MS-DOS
formatted floppy disk with up2000fw.txt and up20srm.rom stored.
In SRM console, I invoked `lfu`. In response to lfu requst to type-in
device name, I inserted the floppy and then typed "dva0". After that,
I typed the "up2000fw.txt" when filename is asked. Then it looks like
lfu started reading floppy. But lfu never came back. It stop with floppy
disk drive access LED on.

# It might be that floppy disk reliability is not enough. (I tried 3 disks.)

Please let me know how I can update SRM.

Hello all,

I know this answer may be a bit late, but I ran into the same problem scenario, tried to google for the answer for quite a long time without success, and finally managed to update the firmware, so I thought to share my solution.

The following worked for me with UP2000+ when updating SRM firmware from 5.6 to 5.8:

1) Prepare the floppy as directed. Linux mtools and msdosfs will do fine. Check that all of the sectors in the floppy are readable, e.g. by "dd" or "badblocks".

2) In the SRM console, "set auto_action halt", i.e. set the system to halt to SRM console prompt instead of automatically booting.

3) Switch power off and back on.

4) When the SRM prompt appears, invoke "lfu" and proceed as directed in the update instructions.


Juhana Helovuo

Reply to: