[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#492488: Reproduction of the Iceweasel crashes.

Mike Hommey wrote:
On Sun, Oct 26, 2008 at 08:09:29AM +0100, Mike Hommey wrote:
Note that we *do* use --no-relax on xulrunner-1.9, but in the CFLAGS.
Without it, libxul.so won't build at all ; the same applies to webkit,

Interesting.  I thought --no-relax is a linker, not a compiler, option.

I've tried to compile xulrunner-1.9 from Debian sources. Debian/rules build worked fine, but I can't run debian/rules binary. It falls over trying to find a java compiler that is not available on Alpha. How do I get past the final step of making the Debian packages? Or do I need to? Can I safely do a 'make install' from the source directory and it will install xulrunner-1.9 components in all the correct system places? Or is it likely to also do things that an install of the Debian xulrunner-1.9 packages wouldn't do?

OTOH, the crash on alpha may be unrelated to the other crash we're
trying to tackle.

Yes, it looks that way. I've tried your suggestion of purging the xulrunner-1.9 package and checking that the various /usr/share/xulrunner-1.9, etc., directories are properly cleaned. I found other trash left behind, indeed the packages, libxul0d, libxul-common, and, IIRC, an older version of xulrunner-gnome-support. I purged those too, cleaned directories, then reinstalled xulrunner-1.9. Iceweasel still crashes.

I could reproduce the crash on alpha and spotted it to be caused by
apparently bad g++ optimization on alpha. Adding:
in xulrunner's toolkit/components/url-classifier/src/Makefile.in makes
iceweasel work properly on albeniz.debian.org.

Yes, Bob (compiling firefox) and I (compiling icecat) found that turning off optimisation (for the complete build) resulted in an executable that works. I wonder if -O1 might work okay?


Reply to: