[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Successfull Etch install on a Multia

   I've been trying for the last day to netboot my multia, with zero
success. I'm not sure what the problem is, but the srm console seems to
not try very long at all before it says "bootstrap failure" and starts
over. I'm watching both the /var/log/messages and /var/log/daemon.log on
the server. Dhcp starts up fine and the logs show atftpd starting up and
binding to port 69, and the logs show the bootrequest and bootreply from
the multia. The multia shows that it's getting it's IP and the name of
the /tftpboot/boot.img file. This is the latest one as of yesterday,
although I've tried three older ones as well.
   I've read through several srm how-to's on this. My /tftpboot
directory is owned by nobody:nogroup. Both the dir and the files in it
are all world readable, writable, and executable (chmod 777).
   I've also tried using tftpd and tftpd-hpa as well as atftpd. Atftpd
was what I was using last year when I was trying this, at least then I
was getting the multia to actually boot the image, but didn't have a
serial console cable with proper gender ends to use that, now I do.
   I guess I should say I'm running etch on my intel server, with an
apt-get upgrade just days old. On the multia, I do:
set ewa0_mode Auto-Sensing
set ewa0_protocols bootp
boot ewa0 -proto bootp -fl "console=ttyS0"

   It seems to me tho that last year when I was trying this the srm
console tried a lot longer, that is it would go ......... before giving
up, now it only does two dots worth, and quits.
    And also, since I'm using shorewall on my server, I've opened port
69 udp both from the local net to the firewall and from the firewall to
the local net. Also have tried just killing the firewall while doing
this, but that doesn't seem to be the problem.

Marc Zyngier wrote:
> People,
> Just to let you know, after the long thread that took place here last
> month, that I managed to successfully install Etch on a Multia, using
> a serial console and booting over the network.
> I used the netboot image located there :
> http://people.debian.org/~vorlon/d-i/alpha/2006-03-20/netboot/boot.img
> My configuration :
> Multia VX40, 256MB RAM
> X4.5-819 Firmware (The OpenVMS one...)
> Simply issued a :
>>>> boot ewa0 -proto bootp -fl "console=ttyS0"
> and off the net it boots. Be sure that the ewa0_mode variable in SRM
> is set to the proper ethernet connection.
> I had to remove a 8139 ethernet card, as the kernel was stuck on this
> one, will try to debug that later.
> On reboot, had to append "console=ttyS0" from the aboot prompt, as it
> wasn't added by the installer. Also saw a "Bad page flag" issued from
> the kernel, sounds bad.
> Overall, the install is dead slow, and the machine fells very sluggish
> once booted (it takes several minute to boot with a very basic
> install). My previous 2.6.9 kernel was quite snappy compared to this
> 2.6.15. Maybe that's a gcc-4.0 effect (I used gcc-3.2 before). But
> hey, it works, and that's a start.
> If someone needs help to get her/his Multia running, feel free to
> chime in, I'll be happy to share any gory detail.

Harmon Seaver

Reply to: