[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#388399: FTBFS problems on alpha, mips[el]: Please help debugging


despite all tips, this is still a plea to the people with access to the

Thiemo Seufer <ths@networkno.de> wrote:

> It looks like the build creates font files with root permissions, and
> can't alter them lateron when running without elevated privileges.
> So any environment with real root permissions should show the problem.

No, it does not, I still need the help of someone with access to the
buildds.  I know it does not show the problem, both because I tried and
because I analysed why it cannot.

1. I tried:

$ rm -rf ~/.texmf-var/fonts
$ apt-get source gnuplot
$ cd gnuplot-4.0.0
$ dpkg-buildpackage -d -b -uc -rsudo
dpkg-buildpackage: source package is gnuplot
dpkg-buildpackage: source version is 4.0.0-5
dpkg-buildpackage: source maintainer is Cyril Bouthors <cyril@bouthors.org>
dpkg-buildpackage: host architecture is i386
 sudo debian/rules clean

works without problems, and creates font cache files in
~/.texmf-var/fonts that are *not* owned by root:

$ find .texmf-var/ -user 0    
$ find .texmf-var/ -user frank | wc -l
$ find .texmf-var/  | wc -l

2. I analysed: 

$ export KPATHSEA_DEBUG=512
$ dpkg-buildpackage -d -b -uc -rsudo 2>&1 | tee ../sudo.lg

shows that the call that fails in the build log at
is the first call to mktextfm.  This is a shell script which first
creates the output directory, then changes to it, and writes its output
into a temporary file, mf31966.tmp in this case.  This is where the
script fails.  

The only explanation I currently have is that on the problematic
buildds, the directory exists, but is owned and writable only by root.
The reason for this may actually be a bug in a TeX package, or just a
misconfiguration.  But we won't find out without looking at the systems

Regards, Frank
Frank Küster
Single Molecule Spectroscopy, Protein Folding @ Inst. f. Biochemie, Univ. Zürich
Debian Developer (teTeX/TeXLive)

Reply to: