[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Apt-get Update problem

To go boot your system with the old 2.4.xx kernel you had before you can enter the following at the srm command line:

        boot diskname -flags i

instead of

        boot diskname -flags 0

You then get a aboot command line, where you can navigate and for example boot the kernel that was installed before the upgrade by typing "1" (profile number 1). This is

        boot diskname -flags 1

Hope that helps to start the old kernel. If the mkinitrd updater did not create the links to the old kernel (e.g. vmlinuz.old -> vmlinuz-2.4.27-2; mkinitrd.img.old -> mkinitrd.img-2.4.27-2 inside /boot) you can manually add a specific kernel by entering the full boot command line (try to print out profile 0 or 1 and modifiy the line with a correct kernel command line).


At 17:42 12.05.2006, you wrote:
Le jeudi 11 mai 2006 à 22:01 -0500, Harmon Seaver a écrit :
> On 5/11/06, Philip Kendall <pak21@srcf.ucam.org> wrote:
> > On Thu, May 11, 2006 at 03:32:15PM -0400, Robert Oram wrote:
> > > Hi all,
> > > Now I get "*Alert!  /dev/hda3 does not exist.  Dropping to a shell!*".
> >
> > [ ... ]
> >
> > > I am running Etch kernel 2.6.15-8 on a 164LX.
> >
> > What is your hard disk? Possibly the most usual cause of this is SATA
> > disks, which exist as /dev/hd* under a 2.4 kernel, but /dev/sd* under a
> > 2.6 kernel, so you need to change the root parameter to your kernel.
> >
>     I didn't have this happen with my debian alpha box, but it
> happened with my intel box when I stupidly tried to do a  upgrade from
> stable to testing, and I don't have any SATA or scsi drives in that
> machine. What happened was that I had devfs running and it changed to
> udev?? (can't think right now exactly what it was) and the system no
> longer could find the drives. I tried all sorts of things to repair
> the damage, finally just trashed it and did a whole new install,
> including having to format the partition, which was a bummer since I
> lost an awful lot of hours of work there getting things set up the way
> I wanted, packages installed, etc.
If you used devfs before the upgrade, udev will be configured to use the
devfs syntax, which does not work (well) anymore, as most packages have
been migrated to udev syntax already.
I usually recommend stopping using devfs before the upgrade.
See also my HOWTO here: http://glasnost.beeznest.org/articles/186
Jérôme Warnier
FLOSS Consultant

Uwe Schindler
H.-H.-Meier-Allee 63, D-28213 Bremen
http://www.thetaphi.de - http://www.schindlers-software.de
eMails: uwe@thetaphi.de (private); info@schindlers-software.de (company)
Tel./Fax: +49 700 PCLATEIN (+49 700 72528346)

Schindlers Software - Home of Schindlers PC-LATEIN 3.20
DIE Software zum Lateinlernen!

Reply to: