[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Squid, Dansguardian, SquidGuard on Debian on Alpha

I have a DS20 with two 500Mhz cpus. I originally tried the latest 2.4 SMP release but found it wouldn't run for long, it would hang up. The 2.4 generic release worked OK, though I did have problems with the NICs. It had two Compaq NC3123s installed (these are the Intel based 82559 cards). I replaced them with a Linksys LNE100TX and it's been working fine. I also swapped out the Qlogic scsi cards and replaced them with a Adaptec AHA-2940U card because there was some thought that the Qlogic was causing SMP problems. Although the Adaptec card works fine, SMP still doesn't. I'm now running Linux debian 2.6.15-1-alpha-generic just fine. I fooled around with 2.6.15 SMP, and after a lot of time, I managed to get a version that would boot. But it's so unstable it's not usable. Hopefully SMP will be fixed one day.

(If anyone wants to work with me on getting SMP to work, I'd be happy to help out!)


----- Original Message ----- From: "Mariano Iumiento" <mariano.iumiento@ospedalesantandrea.it>
To: <debian-alpha@lists.debian.org>
Sent: Thursday, March 16, 2006 3:30 AM
Subject: Squid, Dansguardian, SquidGuard on Debian on Alpha

Hi all,

I have 5 Intel based systems with Debian, Squid, Dansguardian and SquidGuard
installed (plus the other basic Debian packages, obviously).

I now have a problem: I've installed Debian on a Compaq DS20E Alpha system
where I installed Squid, Dansguardian and SquidGuard as well.

The purpose is to duplicate the 5 proxy servers that are actually serving a
local network on the more performing Alpha system.

I've installed and downloaded the required packages with the apt-get

I then copied across from one of the 5 proxies the content of the following
direcroties onto the Alpha system:

so that the newly installed system will contain the same proxy and content
filtering settings.

I then made a few changes to the /etc/squid.conf file to support the system
specific settings (i.e. visible_hostname, localhost, cache size, etc.).

Now, the system works really fast when used as a proxy, but the problem is
that after a few minutes that it's working, it appears that the network
connection gets hang. I mean, the system is not reachable anymore from the

I then go on the system console and look at the logs and processes and
everything seems to be running ok.
There are no error logs, no died processes, nothing!!! Just, the system does
not communicate over the network.

If I try to ping any other hosts from the system, it just acts as if the
cable is not connected: no answer.

The strange thing is that to be able to let the system to work again, it is
enough to run /etc/init.d/network restart and the system works again (very
fast!!!) for more few minutes, and so on.

I've obviously tried to change the Ethernet cable, network plug, speed and
mode settings (Half/Duplex + 10/100 + Auto), etc.

If I stop using the system as a proxy from the client, the system stays up
for hours, unless I do not make big network activities (i.e., if I transfer
few files it works fast, if I try to transfer big files, then the same
problem occurs).

Does anybody have any ides or experience on this problem??

I'd really appreciate any suggestions.


To UNSUBSCRIBE, email to debian-alpha-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: