[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X.org and the Matrox Millenium II


On Tue, Jul 19, 2005 at 09:44:31AM -0400, Jay Estabrook wrote:
> On Mon, Jul 18, 2005 at 11:29:31PM -0400, jacob wrote:

> > Today with a day of mixed blessings. I was over-joyed to see X.org 
> > finally make into the Alpha/Sid. However, no amount of convolutions by 
> > myself was sufficient to cause it to work on my "Matrox Graphics, Inc. 
> > MGA 2164W [Millennium II]".

> > Sadly, the settings with which the card worked under 4.3.0.dfsg.1-14 
> > seemed no longer acceptable to the X.org mga_drv. *sigh*

> > After googling (as much as I was up to tonight), I added 'Load "xaa"' to 
> > get rid of the XAA* unresolved symbols. I tried not loading any modules. 
> > Nothing I did seemed to affect the xf86I2C* unresolved symbols, nor the 
> > type 28 Elf_Relocation error (google was strangely silent about this 
> > error). I was able to lock up the display, so it wouldn't change, 
> > regardless of input (although I was still able to switch to tty1, with a 
> > blank screen, and reboot).

> I had the same problems with 6.8.2 (unresolved XAA references and SEGV),
> and was able to solve it by adding in:

> 	Option	"NoInt10"

> to prevent the BIOS emulation step from running.

> This prevented not only the SEGV but the unresolved references as well.

Are you using the Debian xorg packages?  I've tried adding this option, and
it makes no difference.

I think the key here is the oft-repeated error

   Elf_RelocateEntry() Unsupported relocation type 28

at start time; these are pretty certainly an effect of building X with
gcc-4.0, as Debian has just started to do.  Clearly, X's elfloader is once
more not up to the task of handling real-world ELF relocations.

Steve Langasek
postmodern programmer

Attachment: signature.asc
Description: Digital signature

Reply to: