[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

d-i on sarge still not working on my DS20L, for about a year.

After running 2.6.5-1-smp on DS20Ls for almost a year, a disk died on one
of them.  I fsck'd some partitions, but I believe the kernel image (or
initrd) is just not valid, I'm unable to boot.

So I downloaded the daily build d-i for alpha (18-may-2005), and burned me
a cd-rom and booted it.

I found that partman couldn't see the partitions on my disk, which I
wanted to preserve.  The only thing it would give me a choice to do was
select the whole (IDE1) disk and create a new partition table.

Rather than do that, I shell'd out and mounted all the partitions and
verified that everything was there.  I used fdisk and double checked, and
the partitions are there.  So I search around the debian archives and
stumbled across a piece of myself with the same problem a year ago


My solution back then was to give up on sarge and use the woody installer
(2.2.22) and do an upgrade.  I didn't remember that's how I got around it
until I re-read that old message.

So the problem remains.. ..the partitions exist and the current alpha
sarge d-i partman cannot see the partitions.  I even manually mounted them
onto /target and tried to skip those steps, but I can't seem to get that
to work either.


Reply to: