[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: sarge install

Sorry to reply in this way, but I was not member of this list, as this thread was written.


To: debian-alpha@lists.debian.org 
Subject: Re: sarge install 
From: Neil Roeth <neil@debian.org> 
Date: Thu, 9 Oct 2003 21:25:30 -0400 
In-reply-to: <Pine.GSO.4.44.0310091543010.17655-100000@igloo.df.lth.se> 
Message-id: <16262.2698.434791.991732@laptank.occamsrazor.net> 
Old-return-path: <neil@occamsrazor.net> 
References: <16260.50196.433568.891749@laptank.occamsrazor.net><Pine.GSO.4.44.0310091543010.17655-100000@igloo.df.lth.se> 


On Oct  9, Joakim Roubert (jokke@df.lth.se) wrote:
 > On Wed, 8 Oct 2003, Neil Roeth wrote:
 > > VFS: Mounted root (ext2 filesystem).
 > > Mounted devfs on /dev
 > > VFS: Cannot open root device "rd/0" or 00:00
 > > Please append a correct "root=" boot option
 > > Kernel panic: VFS: Unable to mount root fs on 00:00
 > >
 > >        ### and it hung.
 > I've seen stuff like this when I did not include the correct hard disk
 > controller driver. Are you sure you did that, and with the right
 > parameters?

Hmm, I thought it was still working solely off the CD-ROM, since it hadn't
even come close to starting the install.  I thought rd/0 was the ramdisk.  Is
that not correct?

I had this problem too.
I'm using a Digital Alphaworkstation 600a (Miata) and wanted to install sarge this week.
The same error and messages from the kernel.

And now, month later the solution. (Maybe there are others like me, and I want them to find it faster than me.)
The kernel use on the images to install sarge on an Alpha is a 2.4, so I thought the problem is maybe not the ramdisk itself. 
The messages say, the initrd was unpacked and loaded, but not mounted. Kernel 2.4 used (even with devfs) /dev/ram0.
So here are the boot parameter that worked for me (to get beyond this point):

ramdisk_size=16384 initrd=/boot/initrd.gz root=/dev/ram0 devfs=mount,dall

For MILO as complete command for the sarge-cd-install (CD-ROM hdc)
boot hdc:/boot/vmlinuz initrd=/boot/initrd.gz root=/dev/ram0 devfs=mount,dall

        Oliver Faßbender

PGP Public Key available upon request. E-mail olli@intrepid.de with subject GETPGP

Programmers don't die, they just GOSUB without RETURN.

Reply to: