[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ccc

Joakim Roubert wrote:


Today I gave the install of ccc another shot; I've failed so far.
(I suck.)

The latest rpm I found at Compaq was the ccc-
Running apt-get ccc for stable and unstable gives med the
ccc_6.5.9.001-1_alpha.deb, which prompts for ccc-

I tried to rename the RPM in order to cheat the system, thinking it
wouldn't work. It didn't.

Before I try to make a manual workaround, is there a place to get a

The package description gives: http://www.support.compaq.com/alpha-tools/

Hmm, clicking on "Compaq C" leads one down a trail which talks about version 6.2...

OTOH, clicking on the "Enthusiast & Education Program" (on the left-side bar) gives me a registration page, and then a downloads page with a link to "ccc-".

Last time I tried to pump ccc in my system I made .deb-packages with alien
-c as said might work on this list, but when installed, ccc complained
about not finding correct libraries and stuff.

Does anybody have some tricks or advice here?

Hmm. This is the stuff that the .deb does, but there are a lot of symlinks, script runs, etc. involved. I guess the best advice I can give is just to follow the procedure in the postinst: use rpm2cpio to unpack, copy in as postinst does, and run the scripts that postinst does. I think it should work...

Oh wait, just go to http://lyre.mit.edu/~powell/compaq/ and the binary is there. (That should be in the README.Debian... but there is none! Sorry about that. I should stick a note in the templates file.)

So if you can't get 6.5.9, that should solve your problem with 6.5.6.

One warning though: since gcc became gcc-3.2, I haven't been able to build a working cxx. It must be trying to call gcc, which is 3.2, but cxx's name mangling is incompatible with 3.2 so there are always missing symbols (like cout). I've tried to do several things, like forcing it to use gcc-2.95, but it still calls "gcc" which is 3.2, and doesn't want to be convinced to do otherwise. So cxx on unstable right now is dead, for all practical purposes, until someone at Compaq -er- HP decides to make it work on 3.2 -- or make the gcc call configurable. (I suppose you could work-around using a diversion to make gcc be 2.95 again, but that would be ugly.) I can't see how this might give you any trouble with ccc, but it might...

Ah, the joys of closed-source software!


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: