[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ntp problems

On Fri, 2002-09-20 at 22:14, Emile van Bergen wrote:
> On Fri, Sep 20, 2002 at 08:46:13PM +0200, Carlos L.M. wrote:
> > I have tried to configure my alpha station as a time server for my
> > network. My ntp.conf is :
> > 
> > server
> > 
> > But daemon.log returns:
> > 
> > Sep 20 20:46:35 fennica ntpd[1165]: attempt to configure invalid
> > address
> Keep in mind that all of is the loopback network. Any packet
> sent on it is immediately received from it as well. ntp may not like
> that.
> In short: choose a more sensible network address (and please read RFC
> 1918 before choosing a random one!).

This is not true for ntp. ntp uses 'Pseudo IP addresses' in the
127.127.x.y range for the various types of clocks it supports, like GPS
and DCF77 clocks. One of the classes it supports is the local CMOS
clock. This class is number 1, so clocks in this class have an address
of 127.127.1.y. I keep forgetting if you need to start counting them at
0 or 1, so maybe it's instead of See the
refclock.htm file in the ntp-doc package for more information about the
reference clock drivers.

If using doesn't improve things, then I also don't know
what's wrong with this ntp install. I've tried using as the
only server on a Debian unstable X86 system and it appears to be working
(although I'm not patient enough to wait until it synchronizes).

Tot ziens,


Reply to: